summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libowfat')
-rw-r--r--dev-libs/libowfat/Manifest1
-rw-r--r--dev-libs/libowfat/libowfat-0.32-r1.ebuild7
-rw-r--r--dev-libs/libowfat/libowfat-0.32-r5.ebuild16
-rw-r--r--dev-libs/libowfat/libowfat-0.33-r1.ebuild55
4 files changed, 70 insertions, 9 deletions
diff --git a/dev-libs/libowfat/Manifest b/dev-libs/libowfat/Manifest
index f10b19ebb8e9..829ac2cdc3c6 100644
--- a/dev-libs/libowfat/Manifest
+++ b/dev-libs/libowfat/Manifest
@@ -1 +1,2 @@
DIST libowfat-0.32.tar.xz 195820 BLAKE2B 6dc19b947867a9b08eece785378be2493fb7185d1cc334de080ab1c288884fe0b670ece6f3785f051c707cc98afc4d843a262b9761fc9cc68fdf1f1ac8df1eb8 SHA512 c762a1aa27dfb30e2f6da67d1ad16da03d301b2e3cce33c83b69103183a6689a494c8cf8d7d4e26ad5b22130e4e0560d5f3ef6f44b14d706f10e2300ce11ff3b
+DIST libowfat-0.33.tar.xz 213920 BLAKE2B f902279ae2be96a24ff8760e082a16058db06d20f8e9b55ee54731035f142eb1d9058633be31bc975a3916a44d8d1d4372c2b594e317f5957bff32150aa60785 SHA512 03a56bcbc1a58e340c473d260877218a35841a6915a8369381d74463244cd754fc736006344814855c4d33598ad811d51b7fff4ba41c5e6d38d56297903dcaf5
diff --git a/dev-libs/libowfat/libowfat-0.32-r1.ebuild b/dev-libs/libowfat/libowfat-0.32-r1.ebuild
index 77774d4f7f6d..e8be0ec566bc 100644
--- a/dev-libs/libowfat/libowfat-0.32-r1.ebuild
+++ b/dev-libs/libowfat/libowfat-0.32-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -15,8 +15,7 @@ KEYWORDS="amd64 hppa sparc x86"
IUSE="diet"
RDEPEND="diet? ( >=dev-libs/dietlibc-0.33_pre20090721 )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+DEPEND="${RDEPEND}"
pkg_setup() {
# Required for mult/umult64.c to be usable
@@ -25,7 +24,7 @@ pkg_setup() {
src_compile() {
emake \
- CC=$(tc-getCC) \
+ CC="$(tc-getCC)" \
CFLAGS="-I. ${CFLAGS}" \
DIET="${EPREFIX}/usr/bin/diet -Os" \
prefix="${EPREFIX}/usr" \
diff --git a/dev-libs/libowfat/libowfat-0.32-r5.ebuild b/dev-libs/libowfat/libowfat-0.32-r5.ebuild
index c85792782f66..45ea340b25da 100644
--- a/dev-libs/libowfat/libowfat-0.32-r5.ebuild
+++ b/dev-libs/libowfat/libowfat-0.32-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -11,7 +11,7 @@ HOMEPAGE="https://www.fefe.de/libowfat/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+KEYWORDS="amd64 hppa sparc x86"
IUSE="diet"
RDEPEND="diet? ( >=dev-libs/dietlibc-0.33_pre20090721 )"
@@ -38,10 +38,16 @@ src_prepare() {
}
src_compile() {
+ # Primary use case is for code by the same author. Which then fails with
+ # LTO errors. It builds a static library only, anyway. Result: LTO can be
+ # used if you don't upgrade the compiler. If you do, the compiler errors,
+ # or if you are unlucky, ICEs. Just don't use LTO, there is no point...
+ filter-lto
+
emake \
- CC=$(tc-getCC) \
- AR=$(tc-getAR) \
- RANLIB=$(tc-getRANLIB) \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
CFLAGS="-I. ${CFLAGS}" \
DIET="${EPREFIX}/usr/bin/diet -Os" \
prefix="${EPREFIX}/usr" \
diff --git a/dev-libs/libowfat/libowfat-0.33-r1.ebuild b/dev-libs/libowfat/libowfat-0.33-r1.ebuild
new file mode 100644
index 000000000000..456716706290
--- /dev/null
+++ b/dev-libs/libowfat/libowfat-0.33-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="reimplement libdjb - excellent libraries from Dan Bernstein"
+SRC_URI="https://www.fefe.de/${PN}/${P}.tar.xz"
+HOMEPAGE="https://www.fefe.de/libowfat/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="diet"
+
+RDEPEND="diet? ( >=dev-libs/dietlibc-0.33_pre20090721 )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ # Required for mult/umult64.c to be usable
+ append-flags -fomit-frame-pointer
+}
+
+src_compile() {
+ # Primary use case is for code by the same author. Which then fails with
+ # LTO errors. It builds a static library only, anyway. Result: LTO can be
+ # used if you don't upgrade the compiler. If you do, the compiler errors,
+ # or if you are unlucky, ICEs. Just don't use LTO, there is no point...
+ filter-lto
+
+ # workaround for broken dependencies
+ emake headers
+
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ CFLAGS="-I. ${CFLAGS}" \
+ DIET="${EPREFIX}/usr/bin/diet -Os" \
+ prefix="${EPREFIX}/usr" \
+ INCLUDEDIR="${EPREFIX}/usr/include" \
+ $( use diet || echo 'DIET=' )
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ MAN3DIR="${EPREFIX}/usr/share/man/man3" \
+ INCLUDEDIR="${EPREFIX}/usr/include" \
+ install
+
+ mv "${ED}"/usr/share/man/man3/{buffer.3,owfat-buffer.3} || die
+}