summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libretls/libretls-3.3.1.ebuild')
-rw-r--r--dev-libs/libretls/libretls-3.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/libretls/libretls-3.3.1.ebuild b/dev-libs/libretls/libretls-3.3.1.ebuild
new file mode 100644
index 000000000000..82e1f3e0b5a8
--- /dev/null
+++ b/dev-libs/libretls/libretls-3.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Port of libtls from LibreSSL to OpenSSL"
+HOMEPAGE="https://git.causal.agency/libretls/about/"
+SRC_URI="https://causal.agency/libretls/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/openssl:="
+RDEPEND=${DEPEND}
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}