summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libsavitar/libsavitar-3.6.0.ebuild')
-rw-r--r--dev-libs/libsavitar/libsavitar-3.6.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/libsavitar/libsavitar-3.6.0.ebuild b/dev-libs/libsavitar/libsavitar-3.6.0.ebuild
new file mode 100644
index 000000000000..939a582d09b2
--- /dev/null
+++ b/dev-libs/libsavitar/libsavitar-3.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+inherit cmake-utils python-single-r1
+
+MY_PN="libSavitar"
+
+DESCRIPTION="C++ implementation of 3mf loading with SIP python bindings"
+HOMEPAGE="https://github.com/Ultimaker/libSavitar"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86"
+IUSE="+python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/pugixml
+ dev-python/sip[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.3.0-remove-packaged-pugixml.patch )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PYTHON=$(usex python ON OFF)
+ -DBUILD_STATIC=$(usex static-libs ON OFF)
+ )
+ use python && mycmakeargs+=( -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
+ cmake-utils_src_configure
+}