summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libsavitar/libsavitar-4.3.0-r1.ebuild')
-rw-r--r--dev-libs/libsavitar/libsavitar-4.3.0-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-libs/libsavitar/libsavitar-4.3.0-r1.ebuild b/dev-libs/libsavitar/libsavitar-4.3.0-r1.ebuild
deleted file mode 100644
index 599349de9add..000000000000
--- a/dev-libs/libsavitar/libsavitar-4.3.0-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-inherit cmake python-single-r1
-
-MY_PN="libSavitar"
-
-DESCRIPTION="C++ implementation of 3mf loading with SIP python bindings"
-HOMEPAGE="https://github.com/Ultimaker/libSavitar"
-SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0/3"
-KEYWORDS="~amd64 ~x86"
-IUSE="+python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="${PYTHON_DEPS}
- dev-libs/pugixml
- $(python_gen_cond_dep '
- dev-python/sip[${PYTHON_MULTI_USEDEP}]
- ')"
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-PATCHES=( "${FILESDIR}"/${PN}-4.2.0-remove-packaged-pugixml.patch )
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # Find SIP for current python version, not the latest installed
- sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" CMakeLists.txt || die
- sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" cmake/FindSIP.cmake || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_PYTHON=$(usex python ON OFF)
- -DBUILD_STATIC=$(usex static-libs ON OFF)
- )
-
- cmake_src_configure
-}