summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libtommath')
-rw-r--r--dev-libs/libtommath/Manifest1
-rw-r--r--dev-libs/libtommath/libtommath-1.2.0-r2.ebuild96
2 files changed, 0 insertions, 97 deletions
diff --git a/dev-libs/libtommath/Manifest b/dev-libs/libtommath/Manifest
index 701ebd802e6a..433619a4f62c 100644
--- a/dev-libs/libtommath/Manifest
+++ b/dev-libs/libtommath/Manifest
@@ -1,2 +1 @@
-DIST ltm-1.2.0.tar.xz 622120 BLAKE2B 1537dad7da5c14264f03280e9d49fa0b7e6c1c4924c805f202d31c60569b9e3bee40674301d67b0f5b049c1c2dc5ec71b6c566ff5c9b8168d16840b031acc400 SHA512 6f9ccd0691831f07f86ddc81cb6145504b3d5da66dd3e92312c64cce0ea986fa4e08ba65ca8991aaebe56702c2d7c15f309696785b813dffb4c112a4ad04b203
DIST ltm-1.2.1.tar.xz 635728 BLAKE2B b1464843af4a33f2ba0c824fe2dd080227c6b761b3f8059bbc5229f36d601aecc8bcb20c386718c71a1bc01f69e532647689b43252bd15143f809f7072de449e SHA512 50c9459357aa7f5076af93de6701c617da0dbbf2230a2f4468062704a6cd6e9d3c2fbb27016f68a7e1d6b35d6ddb2088630b24ea6acc20ed8c19594913d36e95
diff --git a/dev-libs/libtommath/libtommath-1.2.0-r2.ebuild b/dev-libs/libtommath/libtommath-1.2.0-r2.ebuild
deleted file mode 100644
index f17fc77a6642..000000000000
--- a/dev-libs/libtommath/libtommath-1.2.0-r2.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools toolchain-funcs
-
-DESCRIPTION="Optimized and portable routines for integer theoretic applications"
-HOMEPAGE="https://www.libtom.net/"
-SRC_URI="https://github.com/libtom/libtommath/releases/download/v${PV}/ltm-${PV}.tar.xz"
-
-LICENSE="Unlicense"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="doc examples static-libs"
-
-BDEPEND="dev-build/libtool"
-
-PATCHES=(
- "${FILESDIR}"/${P}-sparc.patch
-)
-
-src_prepare() {
- default
-
- # need libtool for cross compilation, bug #376643
- cat <<-EOF > configure.ac
- AC_INIT(libtommath, 0)
- AM_INIT_AUTOMAKE
- LT_INIT
- AC_CONFIG_FILES(Makefile)
- AC_OUTPUT
- EOF
-
- touch NEWS README AUTHORS ChangeLog Makefile.am || die
-
- eautoreconf
-
- export LIBTOOL="${S}"/libtool
-}
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-_emake() {
- emake \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- IGNORE_SPEED=1 \
- DESTDIR="${ED}" \
- PREFIX="${EPREFIX}/usr" \
- LIBPATH="/usr/$(get_libdir)" \
- INCPATH="/usr/include" \
- "$@"
-}
-
-src_compile() {
- # Replace hard-coded libdir=${exec_prefix}/lib.
- sed -i -e "/libdir=/s:/lib:/$(get_libdir):" libtommath.pc.in || die
-
- _emake -f makefile.shared
-}
-
-src_test() {
- # Tests must be built statically
- # (i.e. without -f makefile.shared)
- _emake test
-
- ./test || die
-}
-
-src_install() {
- _emake -f makefile.shared install
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- local path="usr/$(get_libdir)/libtommath.${PV}.dylib"
- install_name_tool -id "${EPREFIX}/${path}" "${ED}/${path}" || die "Failed to adjust install_name"
- fi
-
- # We only link against -lc, so drop the .la file.
- find "${ED}" -name '*.la' -delete || die
- if ! use static-libs ; then
- find "${ED}" -name "*.a" -delete || die
- fi
-
- dodoc changes.txt
-
- use doc && dodoc doc/*.pdf
-
- if use examples ; then
- docinto demo
- dodoc demo/*.c
- fi
-}