summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libtompoly')
-rw-r--r--dev-libs/libtompoly/Manifest1
-rw-r--r--dev-libs/libtompoly/libtompoly-0.04.ebuild33
-rw-r--r--dev-libs/libtompoly/metadata.xml23
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libtompoly/Manifest b/dev-libs/libtompoly/Manifest
new file mode 100644
index 000000000000..323791b98288
--- /dev/null
+++ b/dev-libs/libtompoly/Manifest
@@ -0,0 +1 @@
+DIST ltp-0.04.tar.bz2 171966 SHA256 6ce0d39caeda866b8f81029e8354efb9d5393850e78ea24f64475bd87b97fc0b SHA512 64a0b25eb058fc2475e6c645138729796099081ad7e926b58d2e83468d988048607e26716b4b669f0e923ea74d4d9705ff5a0466eb41cbe160488d0173447234 WHIRLPOOL 7d05ba4911a715162c2d2668eb929ed2285e6477c90c741efe49660f9c497a5d6713745aa915b8d05a5be52d334781375bd151ae3a43476a6d3ac2c56a22667d
diff --git a/dev-libs/libtompoly/libtompoly-0.04.ebuild b/dev-libs/libtompoly/libtompoly-0.04.ebuild
new file mode 100644
index 000000000000..df09fb0a8018
--- /dev/null
+++ b/dev-libs/libtompoly/libtompoly-0.04.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="portable ISO C library for polynomial basis arithmetic"
+HOMEPAGE="http://poly.libtomcrypt.org/"
+SRC_URI="http://poly.libtomcrypt.org/files/ltp-${PV}.tar.bz2"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-libs/libtommath"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's:\<ar\>:$(AR):' \
+ -e "/^LIBPATH/s:/lib:/$(get_libdir):" \
+ makefile || die
+ tc-export AR CC
+}
+
+src_install() {
+ default
+ dodoc changes.txt *.pdf
+ docinto demo ; dodoc demo/*
+}
diff --git a/dev-libs/libtompoly/metadata.xml b/dev-libs/libtompoly/metadata.xml
new file mode 100644
index 000000000000..5a6046eed7c4
--- /dev/null
+++ b/dev-libs/libtompoly/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ LibTomPoly has the following features.
+
+ * Totally public domain and is only dependent on LibTomMath, another public
+ domain library.
+ * Portable source code.
+ * Provides access to polynomials of finite characteristic of varying degrees
+ (it will grow to accomodate)
+ * Includes several algebraic operations.
+ o Usual addition, subtraction, division, multiplication.
+ o Modular versions of the add/sub/mul
+ o Modular exponentiation
+ o Irreducibility testing.
+ o Monic reductions
+ o Comparisons
+ </longdescription>
+</pkgmetadata>