summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libucl/libucl-0.8.1-r100.ebuild')
-rw-r--r--dev-libs/libucl/libucl-0.8.1-r100.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/dev-libs/libucl/libucl-0.8.1-r100.ebuild b/dev-libs/libucl/libucl-0.8.1-r100.ebuild
index 2eb9fa97c158..7452ade35ada 100644
--- a/dev-libs/libucl/libucl-0.8.1-r100.ebuild
+++ b/dev-libs/libucl/libucl-0.8.1-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -35,6 +35,14 @@ RDEPEND="${DEPEND}"
DOCS=( README.md doc/api.md )
+PATCHES=(
+ "${FILESDIR}"/${P}-openssl-1.1.1.patch
+)
+
+pkg_setup() {
+ use lua && lua_pkg_setup
+}
+
src_prepare() {
default
rm tests/schema/{definitions,ref{,Remote}}.json || die
@@ -42,8 +50,6 @@ src_prepare() {
}
src_configure() {
- use lua && lua_setup
-
local myeconfargs=(
"$(use_enable lua)"
"$(use_enable regex)"
@@ -58,10 +64,6 @@ src_configure() {
econf "${myeconfargs[@]}"
}
-src_test() {
- emake check
-}
-
src_install() {
default
use lua && DOCS+=( "doc/lua_api.md" )