summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libugpio/libugpio-0.0.7-r1.ebuild')
-rw-r--r--dev-libs/libugpio/libugpio-0.0.7-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libugpio/libugpio-0.0.7-r1.ebuild b/dev-libs/libugpio/libugpio-0.0.7-r1.ebuild
new file mode 100644
index 000000000000..649d6f40165c
--- /dev/null
+++ b/dev-libs/libugpio/libugpio-0.0.7-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info
+
+DESCRIPTION="Lib for the use of linux kernel's sysfs gpio interface from C programs"
+HOMEPAGE="https://github.com/mhei/libugpio"
+SRC_URI="https://github.com/mhei/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+
+CONFIG_CHECK="~CONFIG_GPIO_SYSFS"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}