summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/log4cxx/log4cxx-1.2.0.ebuild')
-rw-r--r--dev-libs/log4cxx/log4cxx-1.2.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/log4cxx/log4cxx-1.2.0.ebuild b/dev-libs/log4cxx/log4cxx-1.2.0.ebuild
new file mode 100644
index 000000000000..dc2e7294b417
--- /dev/null
+++ b/dev-libs/log4cxx/log4cxx-1.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P=apache-${P}
+DESCRIPTION="Library of C++ classes for logging to files, syslog and other destinations"
+HOMEPAGE="https://logging.apache.org/log4cxx/"
+SRC_URI="mirror://apache/logging/${PN}/${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/15"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="odbc smtp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/apr:1=
+ dev-libs/apr-util:1=
+ dev-libs/libfmt:=
+ odbc? ( dev-db/unixODBC )
+ smtp? ( net-libs/libesmtp )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/zip
+ test? (
+ app-alternatives/gzip
+ app-arch/zip
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_FMT_LAYOUT=ON
+ -DLOG4CXX_QT_SUPPORT=OFF
+ -DLOG4CXX_ENABLE_ODBC=$(usex odbc ON OFF)
+ -DLOG4CXX_ENABLE_ESMTP=$(usex smtp ON OFF)
+ )
+
+ cmake_src_configure
+}