summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/mathjax/mathjax-2.7.4.ebuild')
-rw-r--r--dev-libs/mathjax/mathjax-2.7.4.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-libs/mathjax/mathjax-2.7.4.ebuild b/dev-libs/mathjax/mathjax-2.7.4.ebuild
deleted file mode 100644
index f27ee1117965..000000000000
--- a/dev-libs/mathjax/mathjax-2.7.4.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit vcs-clean
-
-DESCRIPTION="JavaScript display engine for LaTeX, MathML and AsciiMath"
-HOMEPAGE="https://www.mathjax.org/"
-SRC_URI="https://github.com/mathjax/MathJax/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/MathJax-${PV}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 hppa ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-RESTRICT="binchecks strip"
-
-make_webconf() {
- # web server config file - should we really do this?
- cat > $1 <<-EOF
- Alias /MathJax/ ${EPREFIX}${webinstalldir}/
- Alias /mathjax/ ${EPREFIX}${webinstalldir}/
-
- <Directory ${EPREFIX}${webinstalldir}>
- Options None
- AllowOverride None
- Order allow,deny
- Allow from all
- </Directory>
- EOF
-}
-
-src_prepare() {
- default
- egit_clean
-}
-
-src_install() {
- local DOCS=( README* )
- use doc && local HTML_DOCS=( docs/html/* )
- default
- if use examples; then
- insinto /usr/share/${PN}/examples
- doins -r test/*
- fi
- rm -r test docs LICENSE README* || die
-
- webinstalldir=/usr/share/${PN}
- insinto ${webinstalldir}
- doins -r *
-
- make_webconf MathJax.conf
- insinto /etc/httpd/conf.d
- doins MathJax.conf
-}