summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/miniz/miniz-2.1.0.ebuild')
-rw-r--r--dev-libs/miniz/miniz-2.1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/miniz/miniz-2.1.0.ebuild b/dev-libs/miniz/miniz-2.1.0.ebuild
new file mode 100644
index 000000000000..1141b3f020ce
--- /dev/null
+++ b/dev-libs/miniz/miniz-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A mesh slicer to generate G-code for fused-filament-fabrication (3D printers)"
+HOMEPAGE="https://github.com/richgel999/miniz"
+SRC_URI="https://github.com/richgel999/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DOCS=( ChangeLog.md LICENSE readme.md )
+
+src_prepare() {
+ sed -i -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' CMakeLists.txt
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ CMAKE_BUILD_TYPE=Release
+
+ cmake_src_configure
+}