summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild')
-rw-r--r--dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild b/dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild
index 5907ed5bf1a1..14639036b47e 100644
--- a/dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild
+++ b/dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild
@@ -47,14 +47,19 @@ PATCHES=()
if [[ ${PV} == *_p* ]] ; then
# Apply the upstream patches released out of band
PATCHES+=( "${DISTDIR}"/ )
-
- # One-off partial revert of 4.1.0_p13's patch10
- # Won't be needed on next release.
- PATCHES+=( "${FILESDIR}"/${P}-revert-doc-changes-patch10.patch )
fi
HTML_DOCS=( doc/FAQ.html )
+src_prepare() {
+ default
+
+ # 4.1.0_p13's patch10 patches a .texi file *and* the corresponding
+ # info file. We need to make sure the info file is newer, so the
+ # build doesn't try to run makeinfo. Won't be needed on next release.
+ touch "${S}/doc/mpfr.info" || die
+}
+
multilib_src_configure() {
# bug 476336#19
# Make sure mpfr doesn't go probing toolchains it shouldn't