summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/msgpack/msgpack-2.0.0.ebuild')
-rw-r--r--dev-libs/msgpack/msgpack-2.0.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-libs/msgpack/msgpack-2.0.0.ebuild b/dev-libs/msgpack/msgpack-2.0.0.ebuild
deleted file mode 100644
index 8f7503aa83bb..000000000000
--- a/dev-libs/msgpack/msgpack-2.0.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN}/${PN}-c.git"
-else
- SRC_URI="
- https://github.com/${PN}/${PN}-c/releases/download/cpp-${PV}/${P}.tar.gz
- https://dev.gentoo.org/~monsieurp/dist/${P}-patchset.tar.bz2"
-
- KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="MessagePack is a binary-based efficient data interchange format"
-HOMEPAGE="https://msgpack.org/ https://github.com/msgpack/msgpack-c/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="+cxx static-libs test"
-
-DEPEND="
- test? (
- >=dev-cpp/gtest-1.6.0-r2[${MULTILIB_USEDEP}]
- sys-libs/zlib[${MULTILIB_USEDEP}]
- )
-"
-
-DOCS=( README.md )
-
-PATCHES=(
- "${WORKDIR}"/patchset/${PN}-2.0.0-gcc7-implicit-fallthrough.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DMSGPACK_ENABLE_CXX=$(usex cxx)
- -DMSGPACK_STATIC=$(usex static-libs)
- )
-
- cmake-multilib_src_configure
-}