summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/npth/npth-1.6-r1.ebuild')
-rw-r--r--dev-libs/npth/npth-1.6-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-libs/npth/npth-1.6-r1.ebuild b/dev-libs/npth/npth-1.6-r1.ebuild
index 81b168a55477..bb3c8b84c723 100644
--- a/dev-libs/npth/npth-1.6-r1.ebuild
+++ b/dev-libs/npth/npth-1.6-r1.ebuild
@@ -12,6 +12,8 @@ SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
src_prepare() {
default
@@ -19,7 +21,9 @@ src_prepare() {
}
src_configure() {
- econf --disable-static
+ econf \
+ --disable-static \
+ $(use_enable test tests)
}
src_install() {