summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/npth/npth-1.7.ebuild')
-rw-r--r--dev-libs/npth/npth-1.7.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-libs/npth/npth-1.7.ebuild b/dev-libs/npth/npth-1.7.ebuild
deleted file mode 100644
index 71d952cdae8c..000000000000
--- a/dev-libs/npth/npth-1.7.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools flag-o-matic
-
-DESCRIPTION="New GNU Portable Threads Library"
-HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
-SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
-
- econf $(use_enable test tests)
-}
-
-src_install() {
- default
-
- # no static archives
- find "${ED}" -name '*.la' -delete || die
-}