summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ntl/ntl-6.1.0.ebuild')
-rw-r--r--dev-libs/ntl/ntl-6.1.0.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/dev-libs/ntl/ntl-6.1.0.ebuild b/dev-libs/ntl/ntl-6.1.0.ebuild
index 09dfcc94096e..dfaa592b2e3b 100644
--- a/dev-libs/ntl/ntl-6.1.0.ebuild
+++ b/dev-libs/ntl/ntl-6.1.0.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-
inherit toolchain-funcs eutils multilib flag-o-matic
DESCRIPTION="High-performance and portable Number Theory C++ library"
@@ -15,8 +14,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
IUSE="doc static-libs test"
-RDEPEND="
- >=dev-libs/gmp-4.3:0=
+RDEPEND=">=dev-libs/gmp-4.3
>=dev-libs/gf2x-0.9"
DEPEND="${RDEPEND}
dev-lang/perl"
@@ -26,7 +24,7 @@ S="${WORKDIR}/${P}/src"
src_prepare() {
# fix parallel make
sed -i -e "s/make/make ${MAKEOPTS}/g" WizardAux || die
- cd .. || die
+ cd ..
# enable compatibility with singular
epatch "$FILESDIR/${PN}-6.0.0-singular.patch"
# implement a call back framework (submitted upstream)
@@ -48,30 +46,30 @@ src_configure() {
src_compile() {
# split the targets to allow parallel make to run properly
- emake setup1 setup2
- emake setup3
+ emake setup1 setup2 || die "emake setup failed"
+ emake setup3 || die "emake setup failed"
sh Wizard on || die "Tuning wizard failed"
if use static-libs || use test; then
- emake ntl.a
+ emake ntl.a || die "emake static failed"
fi
local trg=so
[[ ${CHOST} == *-darwin* ]] && trg=dylib
- emake shared${trg}
+ emake shared${trg} || die "emake shared failed"
}
src_install() {
if use static-libs; then
- newlib.a ntl.a libntl.a
+ newlib.a ntl.a libntl.a || die "installation of static library failed"
fi
- dolib.so lib*$(get_libname)
+ dolib.so lib*$(get_libname) || die "installation of shared library failed"
- cd .. || die
+ cd ..
insinto /usr/include
- doins -r include/NTL
+ doins -r include/NTL || die "installation of the headers failed"
dodoc README
if use doc ; then
- dodoc doc/*.txt
- dohtml doc/*
+ dodoc doc/*.txt || die
+ dohtml doc/* || die
fi
}