summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/oniguruma')
-rw-r--r--dev-libs/oniguruma/Manifest4
-rw-r--r--dev-libs/oniguruma/files/oniguruma-5.9.2-makefile.patch42
-rw-r--r--dev-libs/oniguruma/files/oniguruma-5.9.3-makefile.patch48
-rw-r--r--dev-libs/oniguruma/metadata.xml19
-rw-r--r--dev-libs/oniguruma/oniguruma-5.9.2-r1.ebuild38
-rw-r--r--dev-libs/oniguruma/oniguruma-5.9.2.ebuild30
-rw-r--r--dev-libs/oniguruma/oniguruma-5.9.3.ebuild38
-rw-r--r--dev-libs/oniguruma/oniguruma-5.9.4.ebuild38
-rw-r--r--dev-libs/oniguruma/oniguruma-5.9.5.ebuild38
9 files changed, 295 insertions, 0 deletions
diff --git a/dev-libs/oniguruma/Manifest b/dev-libs/oniguruma/Manifest
new file mode 100644
index 000000000000..7692eeb7991d
--- /dev/null
+++ b/dev-libs/oniguruma/Manifest
@@ -0,0 +1,4 @@
+DIST onig-5.9.2.tar.gz 539739 SHA256 10e7b04ca0baaef2c26f32b37bb70d898b3642d38aefd5ad5062a20f86b751f6 SHA512 fedc9ed663e9970c1f44647431085093f792af1273d5fd25713545e6770652f959a78fb059e44ec348f201f40b2aaa9ef8d081721842f4fa7c486def2a73a8e7 WHIRLPOOL 4fcdd5fcde4ab670b2e7e672b2187a488d698fd6172f9b0c1b237d680dc5cfecac4e9262d7b78e32eb782596cdf92a13f554b45ee5566eabf39349c1c7d8884b
+DIST onig-5.9.3.tar.gz 566875 SHA256 c3bba66b2a84760e6582c40881db97c839d94f327870009724bb8b4d0c051f2a SHA512 d673fbd12af78bbe36984eff2aab5e0c043a663f2fca248f7accc0e9d2c86144b5e9635c542ea6311574d680d628893128615dedc32adcbe62ac427f1ead2870 WHIRLPOOL 5b6bd7c5ff0e2b586af776d94351abe8c5203d40a37138386df19eb3877e3940708c0b272f0c3d88361ce26579bd1e253333ee7c30f0af92f69a185503f2f06a
+DIST onig-5.9.4.tar.gz 567985 SHA256 988221911ff865941a859096c39a532df77418cb6df513857428a41605130697 SHA512 d1a8492925c5f873a8bd8cd5b1a3da2c78392ca7160eeadb9c53cf08e0e6dcedf75f95c748595888d727395cd9226a784cdf38ef5d64665a3c4b27e45da84cb6 WHIRLPOOL 9dd36b4bc4408360baeac39ad9c7ee3f4e231dd9ca57ffc5d07598a7ad5d2f9b03ca37d63399aa78ef55c0264453f83cb82155c2d2e09d3c8804f4e6954f763f
+DIST onig-5.9.5.tar.gz 587874 SHA256 9f49ae7819a5f47e25449d0e4b010d479f7868a24a7b9884b47041b49a76438a SHA512 3ba3c94c5e52c80c680ebf1d19be53fa5a94a11d622e0282184c7a9c8cc6676f1926b97d12aafc66514071e65cd7de2bd4632afb053c69b01ddb8b581e878252 WHIRLPOOL 4f8a52fc682c15a96660049159e98ddd9f68170e2cba3948f73f3105a266bce8b4c42329b4dc0d6f94472fd9139bbd9a8ebbf3f7351a95c868e78999ce276ece
diff --git a/dev-libs/oniguruma/files/oniguruma-5.9.2-makefile.patch b/dev-libs/oniguruma/files/oniguruma-5.9.2-makefile.patch
new file mode 100644
index 000000000000..bd594e395631
--- /dev/null
+++ b/dev-libs/oniguruma/files/oniguruma-5.9.2-makefile.patch
@@ -0,0 +1,42 @@
+--- Makefile.am.orig 2012-08-08 10:29:20.313862377 +0100
++++ Makefile.am 2012-08-08 10:29:30.793762591 +0100
+@@ -5,7 +5,7 @@
+
+ #AM_CFLAGS = -DNOT_RUBY
+ AM_CFLAGS =
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ SUBDIRS = . sample
+
+--- sample/Makefile.am.orig 2012-08-08 11:37:49.813512228 +0100
++++ sample/Makefile.am 2012-08-08 11:38:00.289410756 +0100
+@@ -2,7 +2,7 @@
+
+ libname = $(top_builddir)/libonig.la
+ LDADD = $(libname)
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ encode_SOURCES = encode.c
+ listcap_SOURCES = listcap.c
+--- configure.in.orig
++++ configure.in
+@@ -23,7 +23,7 @@
+ AC_ARG_ENABLE(combination-explosion-check,
+ [ --enable-combination-explosion-check enable combination explosion check],
+ [comb_expl_check=$enableval])
+-if test $comb_expl_check = yes; then
++if test "x$comb_expl_check" = xyes; then
+ AC_DEFINE(USE_COMBINATION_EXPLOSION_CHECK,1,[Define if combination explosion check])
+ fi
+
+@@ -31,7 +31,7 @@
+ AC_ARG_ENABLE(crnl-as-line-terminator,
+ [ --enable-crnl-as-line-terminator enable CR+NL as line terminator],
+ [crnl_as_line_terminator=$enableval])
+-if test $crnl_as_line_terminator = yes; then
++if test "x$crnl_as_line_terminator" = xyes; then
+ AC_DEFINE(USE_CRNL_AS_LINE_TERMINATOR,1,[Define if enable CR+NL as line terminator])
+ fi
+
diff --git a/dev-libs/oniguruma/files/oniguruma-5.9.3-makefile.patch b/dev-libs/oniguruma/files/oniguruma-5.9.3-makefile.patch
new file mode 100644
index 000000000000..7003907f7850
--- /dev/null
+++ b/dev-libs/oniguruma/files/oniguruma-5.9.3-makefile.patch
@@ -0,0 +1,48 @@
+diff --git a/Makefile.am b/Makefile.am
+index 2865fb7..75cbd45 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -6,7 +6,7 @@ libname = libonig.la
+ ACLOCAL_AMFLAGS = -I m4
+ #AM_CFLAGS = -DNOT_RUBY
+ AM_CFLAGS =
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ SUBDIRS = . sample
+
+diff --git a/configure.in b/configure.in
+index 1e21f96..51b56d8 100644
+--- a/configure.in
++++ b/configure.in
+@@ -25,7 +25,7 @@ dnl check for COMBINATION_EXPLOSION
+ AC_ARG_ENABLE(combination-explosion-check,
+ [ --enable-combination-explosion-check enable combination explosion check],
+ [comb_expl_check=$enableval])
+-if test "${comb_expl_check}" = yes; then
++if test "x${comb_expl_check}" = xyes; then
+ AC_DEFINE(USE_COMBINATION_EXPLOSION_CHECK,1,[Define if combination explosion check])
+ fi
+
+@@ -33,7 +33,7 @@ dnl check for CRNL_AS_LINE_TERMINATOR
+ AC_ARG_ENABLE(crnl-as-line-terminator,
+ [ --enable-crnl-as-line-terminator enable CR+NL as line terminator],
+ [crnl_as_line_terminator=$enableval])
+-if test "${crnl_as_line_terminator}" = yes; then
++if test "x${crnl_as_line_terminator}" = xyes; then
+ AC_DEFINE(USE_CRNL_AS_LINE_TERMINATOR,1,[Define if enable CR+NL as line terminator])
+ fi
+
+diff --git a/sample/Makefile.am b/sample/Makefile.am
+index af33057..347af94 100644
+--- a/sample/Makefile.am
++++ b/sample/Makefile.am
+@@ -2,7 +2,7 @@ noinst_PROGRAMS = encode listcap names posix simple sql syntax crnl
+
+ libname = $(top_builddir)/libonig.la
+ LDADD = $(libname)
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ encode_SOURCES = encode.c
+ listcap_SOURCES = listcap.c
diff --git a/dev-libs/oniguruma/metadata.xml b/dev-libs/oniguruma/metadata.xml
new file mode 100644
index 000000000000..cbabf9d6775f
--- /dev/null
+++ b/dev-libs/oniguruma/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+<longdescription>
+Oniguruma is a regular expression library. The characteristics of
+this library is that different character encoding for every regular
+expression object can be specified. (Supported character encodings:
+ASCII, UTF-8, EUC-JP, Shift_JIS)
+</longdescription>
+<use>
+ <flag name="combination-explosion-check">
+ enable combination explosion check
+ </flag>
+ <flag name="crnl-as-line-terminator">
+ enable CR+NL as line terminator
+ </flag>
+</use>
+</pkgmetadata>
diff --git a/dev-libs/oniguruma/oniguruma-5.9.2-r1.ebuild b/dev-libs/oniguruma/oniguruma-5.9.2-r1.ebuild
new file mode 100644
index 000000000000..2cfa75a1ad58
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-5.9.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+# Needed for a sane .so versionning on fbsd, please dont drop
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils autotools-utils
+
+MY_P=onig-${PV}
+
+DESCRIPTION="a regular expression library for different character encodings"
+HOMEPAGE="http://www.geocities.jp/kosako3/oniguruma"
+SRC_URI="http://www.geocities.jp/kosako3/oniguruma/archive/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="combination-explosion-check crnl-as-line-terminator static-libs"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+DOCS=( AUTHORS HISTORY README{,.ja} doc/{API,FAQ,RE}{,.ja} )
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable combination-explosion-check)
+ $(use_enable crnl-as-line-terminator)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use static-libs || prune_libtool_files
+}
diff --git a/dev-libs/oniguruma/oniguruma-5.9.2.ebuild b/dev-libs/oniguruma/oniguruma-5.9.2.ebuild
new file mode 100644
index 000000000000..39f55969e5c4
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-5.9.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit libtool
+
+MY_P=onig-${PV}
+
+DESCRIPTION="a regular expression library for different character encodings"
+HOMEPAGE="http://www.geocities.jp/kosako3/oniguruma"
+SRC_URI="http://www.geocities.jp/kosako3/oniguruma/archive/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Needed for a sane .so versionning on fbsd, please dont drop
+ elibtoolize
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS HISTORY README* doc/*
+}
diff --git a/dev-libs/oniguruma/oniguruma-5.9.3.ebuild b/dev-libs/oniguruma/oniguruma-5.9.3.ebuild
new file mode 100644
index 000000000000..b7d879e386ca
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-5.9.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+# Needed for a sane .so versionning on fbsd, please dont drop
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils autotools-utils
+
+MY_P=onig-${PV}
+
+DESCRIPTION="a regular expression library for different character encodings"
+HOMEPAGE="http://www.geocities.jp/kosako3/oniguruma"
+SRC_URI="http://www.geocities.jp/kosako3/oniguruma/archive/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="combination-explosion-check crnl-as-line-terminator static-libs"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+DOCS=( AUTHORS HISTORY README{,.ja} doc/{API,FAQ,RE}{,.ja} )
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable combination-explosion-check)
+ $(use_enable crnl-as-line-terminator)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use static-libs || prune_libtool_files
+}
diff --git a/dev-libs/oniguruma/oniguruma-5.9.4.ebuild b/dev-libs/oniguruma/oniguruma-5.9.4.ebuild
new file mode 100644
index 000000000000..36cbe4775fbc
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-5.9.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+# Needed for a sane .so versionning on fbsd, please dont drop
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils autotools-utils
+
+MY_P=onig-${PV}
+
+DESCRIPTION="a regular expression library for different character encodings"
+HOMEPAGE="http://www.geocities.jp/kosako3/oniguruma"
+SRC_URI="http://www.geocities.jp/kosako3/oniguruma/archive/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="combination-explosion-check crnl-as-line-terminator static-libs"
+
+PATCHES=( "${FILESDIR}"/${PN}-5.9.3-makefile.patch )
+DOCS=( AUTHORS HISTORY README{,.ja} doc/{API,FAQ,RE}{,.ja} )
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable combination-explosion-check)
+ $(use_enable crnl-as-line-terminator)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use static-libs || prune_libtool_files
+}
diff --git a/dev-libs/oniguruma/oniguruma-5.9.5.ebuild b/dev-libs/oniguruma/oniguruma-5.9.5.ebuild
new file mode 100644
index 000000000000..c5d6492fee5a
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-5.9.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+# Needed for a sane .so versionning on fbsd, please dont drop
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils autotools-multilib
+
+MY_P=onig-${PV}
+
+DESCRIPTION="a regular expression library for different character encodings"
+HOMEPAGE="http://www.geocities.jp/kosako3/oniguruma"
+SRC_URI="http://www.geocities.jp/kosako3/oniguruma/archive/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="combination-explosion-check crnl-as-line-terminator static-libs"
+
+PATCHES=( "${FILESDIR}"/${PN}-5.9.3-makefile.patch )
+DOCS=( AUTHORS HISTORY README{,.ja} doc/{API,FAQ,RE}{,.ja} )
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable combination-explosion-check)
+ $(use_enable crnl-as-line-terminator)
+ )
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+ use static-libs || prune_libtool_files
+}