summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/openct/openct-0.6.20-r5.ebuild')
-rw-r--r--dev-libs/openct/openct-0.6.20-r5.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-libs/openct/openct-0.6.20-r5.ebuild b/dev-libs/openct/openct-0.6.20-r5.ebuild
index 12d4c000e8c6..6183a18acb12 100644
--- a/dev-libs/openct/openct-0.6.20-r5.ebuild
+++ b/dev-libs/openct/openct-0.6.20-r5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic udev
+inherit autotools flag-o-matic udev
DESCRIPTION="library for accessing smart card terminals"
HOMEPAGE="https://github.com/OpenSC/openct/wiki"
@@ -27,6 +27,16 @@ RDEPEND="
"
BDEPEND="doc? ( app-doc/doxygen )"
+PATCHES=(
+ "${FILESDIR}"/${P}-automake.patch
+ "${FILESDIR}"/${P}-slibtool.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
use debug && append-cppflags -DDEBUG_IFDH