summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/papi')
-rw-r--r--dev-libs/papi/Manifest2
-rw-r--r--dev-libs/papi/papi-5.3.0.ebuild38
-rw-r--r--dev-libs/papi/papi-5.4.0.ebuild38
-rw-r--r--dev-libs/papi/papi-5.5.1.ebuild24
4 files changed, 16 insertions, 86 deletions
diff --git a/dev-libs/papi/Manifest b/dev-libs/papi/Manifest
index 2596b29b77ef..2ca09701fd23 100644
--- a/dev-libs/papi/Manifest
+++ b/dev-libs/papi/Manifest
@@ -1,3 +1 @@
-DIST papi-5.3.0.tar.gz 3928589 BLAKE2B 64531442b5ebe846ba801455c3cb15437ee2d5eec8b4d567f4bf96f1c08e2af26aedcae0c5601e00e5454aa5ad5d482a6b113a52a20d5b2819161c82b51f8fb5 SHA512 a88d28d895a1b44b0d05ac90c39406b7e9806a1d865b39df405e55b27d7f6bb191330ed7df52d4f3f04f46ff94ce867e6c1bdd9b38c314652cff1ee9d838b226
-DIST papi-5.4.0.tar.gz 4075657 BLAKE2B 17d92eb379ef7c45071c32ca0bbf9baecd0044ed019a2aa731da32d9bb92fad707375f555dc87adc1a8e90e27d2d850c673fbc71c3f2a55f8621151ff21087bc SHA512 be4a929208a83765f99f2f34e98d6770bf46d4f336e492506cc86d6a34fbf84754b05cfd22db0949b382bb8f24ad0ed7f5e7c90941baad2593b82827ee27eb4a
DIST papi-5.5.1.tar.gz 4233127 BLAKE2B e065bed5a5607bf5ce3459ea84e1dabd6a60cd1f78f3ec2fbed29676ff79a057c77bd4210b8c45428238d927016a5a1e16d7bdfb4a9f56ea1e180cb0b19ec182 SHA512 c65c3a4e95c33ee7ceb950c184c08019d83cfee38bfe1bac86e80670a5191918edab2916b6815b15001da961deb8b6cf51263541554eb92a817e1a48371cfcf5
diff --git a/dev-libs/papi/papi-5.3.0.ebuild b/dev-libs/papi/papi-5.3.0.ebuild
deleted file mode 100644
index e2aa6283e644..000000000000
--- a/dev-libs/papi/papi-5.3.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-inherit autotools-utils fortran-2 versionator
-
-DESCRIPTION="Performance Application Programming Interface"
-HOMEPAGE="http://icl.cs.utk.edu/papi/"
-SRC_URI="http://icl.cs.utk.edu/projects/${PN}/downloads/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
-
-DEPEND="
- dev-libs/libpfm[static-libs]
- virtual/mpi
-"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)/src"
-
-src_configure() {
- local myeconfargs=(
- --with-shlib
- --with-perf-events
- --with-pfm-prefix="${EPREFIX}/usr"
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
- dodoc ../RE*
-}
diff --git a/dev-libs/papi/papi-5.4.0.ebuild b/dev-libs/papi/papi-5.4.0.ebuild
deleted file mode 100644
index 9a415cc1b998..000000000000
--- a/dev-libs/papi/papi-5.4.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-inherit autotools-utils fortran-2 versionator
-
-DESCRIPTION="Performance Application Programming Interface"
-HOMEPAGE="http://icl.cs.utk.edu/papi/"
-SRC_URI="http://icl.cs.utk.edu/projects/${PN}/downloads/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
-
-DEPEND="
- dev-libs/libpfm[static-libs]
- virtual/mpi
-"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)/src"
-
-src_configure() {
- local myeconfargs=(
- --with-shlib
- --with-perf-events
- --with-pfm-prefix="${EPREFIX}/usr"
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
- dodoc ../RE*
-}
diff --git a/dev-libs/papi/papi-5.5.1.ebuild b/dev-libs/papi/papi-5.5.1.ebuild
index 0d2f0f2c48e2..08fa56644ba3 100644
--- a/dev-libs/papi/papi-5.5.1.ebuild
+++ b/dev-libs/papi/papi-5.5.1.ebuild
@@ -1,38 +1,46 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_IN_SOURCE_BUILD=1
-inherit autotools-utils fortran-2 versionator
+inherit autotools fortran-2
DESCRIPTION="Performance Application Programming Interface"
HOMEPAGE="http://icl.cs.utk.edu/papi/"
SRC_URI="http://icl.cs.utk.edu/projects/${PN}/downloads/${P}.tar.gz"
+S="${WORKDIR}/${PN}-$(ver_cut 1-3)/src"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
DEPEND="
- dev-libs/libpfm[static-libs]
+ dev-libs/libpfm
virtual/mpi
"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)/src"
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+ eautoreconf
+}
src_configure() {
local myeconfargs=(
--with-shlib
--with-perf-events
--with-pfm-prefix="${EPREFIX}/usr"
+ --with-shared-lib=yes
+ --with-static-lib=no
)
- autotools-utils_src_configure
+
+ econf "${myeconfargs[@]}"
}
src_install() {
- autotools-utils_src_install
+ default
+
dodoc ../RE*
}