summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/purpose/purpose-1.1.ebuild')
-rw-r--r--dev-libs/purpose/purpose-1.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/purpose/purpose-1.1.ebuild b/dev-libs/purpose/purpose-1.1.ebuild
new file mode 100644
index 000000000000..54a2ef91c374
--- /dev/null
+++ b/dev-libs/purpose/purpose-1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_kdeapps_dep kaccounts-integration)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-libs/accounts-qt
+"
+RDEPEND="${DEPEND}"