summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/qcustomplot/qcustomplot-1.2.1.ebuild')
-rw-r--r--dev-libs/qcustomplot/qcustomplot-1.2.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/qcustomplot/qcustomplot-1.2.1.ebuild b/dev-libs/qcustomplot/qcustomplot-1.2.1.ebuild
new file mode 100644
index 000000000000..7c88dcff13cf
--- /dev/null
+++ b/dev-libs/qcustomplot/qcustomplot-1.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2
+
+DESCRIPTION="Qt C++ widget for plotting and data visualization"
+HOMEPAGE="http://www.qcustomplot.com/"
+SRC_URI="
+ http://www.qcustomplot.com/release/${PV}/QCustomPlot-sharedlib.tar.gz -> ${PN}-sharedlib-${PV}.tar.gz
+ http://www.qcustomplot.com/release/${PV}/QCustomPlot-source.tar.gz -> ${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-source
+
+src_prepare() {
+ sed \
+ -e 's:../../::g' \
+ -e '/CONFIG/s:shared.*:shared:g' \
+ "${WORKDIR}"/${PN}-sharedlib/sharedlib-compilation/sharedlib-compilation.pro > ${PN}.pro || die
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ dolib.so lib${PN}*
+ doheader ${PN}.h
+ dodoc changelog.txt
+}