summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/raft')
-rw-r--r--dev-libs/raft/Manifest3
-rw-r--r--dev-libs/raft/files/raft-0.9.25-Always-skip-init-oom-test.patch31
-rw-r--r--dev-libs/raft/metadata.xml3
-rw-r--r--dev-libs/raft/raft-0.22.0.ebuild (renamed from dev-libs/raft/raft-0.11.2.ebuild)19
-rw-r--r--dev-libs/raft/raft-0.22.1.ebuild60
5 files changed, 77 insertions, 39 deletions
diff --git a/dev-libs/raft/Manifest b/dev-libs/raft/Manifest
index 310531d32c3c..3f7e7e8f6977 100644
--- a/dev-libs/raft/Manifest
+++ b/dev-libs/raft/Manifest
@@ -1 +1,2 @@
-DIST raft-0.11.2.tar.gz 325098 BLAKE2B d9366547440b431edec75a22bca3a50bb6d714b5d950c061723f0585c5ad33704d23c32f2e325dc566ebeab71e15e10f07932c854657837e190901b52c9b4950 SHA512 8be47270cf3b888ff6adeeec2480ccd5065b45c3c546da089cbb326cf429f0bcd4396001e20fbf52587c00d5757337812c834ec5064fafa4815a978a7cf0c35f
+DIST raft-0.22.0.tar.gz 365710 BLAKE2B b5084867ebd7e80f59edebcf5feb83cc7ffbf798deecbf96d3b31c0de7213c8fc1e3e5f558602f5864fb04f8de0326ee2f70d2f6164a08dd444a8db95593c328 SHA512 0ebda5764c866443ee2749c0c8fe798f111ed500b9d59bc9536d01e01ee82a8ed72125fb02e6a0c3bf51e4004520d4c5fdb583220599cb22bb9a8e6dd9d1a54b
+DIST raft-0.22.1.tar.gz 362393 BLAKE2B b6fc8f8e9dc6801ac8ad1b9d94f984b249b83def00a08776292500b079bb777330e8a83cf40153bfb1baae921105788d758c9f61a021d5519d5c27048b6be8b9 SHA512 fb4ea98321336daaa605e1c3cd55f672860fc8894d479fdff4e1862a4eb5622dbaf7a943e030dd2bcdaa14cc639e7e11ac43d71f00bdbd27f12c6b67653b70e4
diff --git a/dev-libs/raft/files/raft-0.9.25-Always-skip-init-oom-test.patch b/dev-libs/raft/files/raft-0.9.25-Always-skip-init-oom-test.patch
deleted file mode 100644
index 7a22682c2e03..000000000000
--- a/dev-libs/raft/files/raft-0.9.25-Always-skip-init-oom-test.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-commit e0948518f6eedad85c7705fb3963cfdda3627d8f
-Author: Reto Gantenbein <reto.gantenbein@linuxmonk.ch>
-Date: Thu Oct 22 00:19:31 2020 +0200
-
- Always skip init/oom test
-
- The RPM package build in COPR is being executed on a tmpfs which
- always results in a failure of this test:
-
- init/oom
- heap-fault-delay=1, heap-fault-repeat=1 [ ERROR ]
- Error: test/integration/test_uv_init.c:156: assertion failed: _rv == 1 (0 == 1)
-
- Instead only for certain architectures we always skip this test.
- For more informations see https://github.com/ganto/copr-lxc4/issues/8
-
-diff --git a/test/integration/test_uv_init.c b/test/integration/test_uv_init.c
-index 8c9b5f7..57db7f3 100644
---- a/test/integration/test_uv_init.c
-+++ b/test/integration/test_uv_init.c
-@@ -144,10 +144,8 @@ static MunitParameterEnum oomParams[] = {
- TEST(init, oom, setUp, tearDown, 0, oomParams)
- {
- struct fixture *f = data;
--#if defined(__i686__)
- /* XXX: tmpfs seems to not support O_DIRECT */
- return MUNIT_SKIP;
--#endif
- #if defined(__powerpc64__)
- /* XXX: fails on ppc64el */
- return MUNIT_SKIP;
diff --git a/dev-libs/raft/metadata.xml b/dev-libs/raft/metadata.xml
index 87e6f87c354e..94076382bb1e 100644
--- a/dev-libs/raft/metadata.xml
+++ b/dev-libs/raft/metadata.xml
@@ -19,4 +19,7 @@
(send/receive RPC messages) and disk persistence (store log entries and
snapshots).
</longdescription>
+ <upstream>
+ <remote-id type="github">cowsql/raft</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-libs/raft/raft-0.11.2.ebuild b/dev-libs/raft/raft-0.22.0.ebuild
index 703d817e51f4..39daa1268bef 100644
--- a/dev-libs/raft/raft-0.11.2.ebuild
+++ b/dev-libs/raft/raft-0.22.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2021 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,11 +6,13 @@ EAPI=8
inherit autotools
DESCRIPTION="C implementation of the Raft consensus protocol"
-HOMEPAGE="https://github.com/canonical/raft"
-SRC_URI="https://github.com/canonical/raft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/cowsql/raft"
+SRC_URI="https://github.com/cowsql/raft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-3-with-linking-exception"
-SLOT="0"
+
+# Upstream change from canonical to cowsql resetted SONAME, 3 -> 0. bgo#915960
+SLOT="0/0"
KEYWORDS="amd64 ~arm64 ~x86"
IUSE="lz4 test zfs"
RESTRICT="!test? ( test )"
@@ -21,9 +23,8 @@ RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/raft-0.9.25-Always-skip-init-oom-test.patch
"${FILESDIR}"/raft-0.10.0-toggle-zfs.patch
- )
+)
src_prepare() {
default
@@ -31,18 +32,22 @@ src_prepare() {
}
src_configure() {
+ # --disable-hardening: most of these are covered on non-hardened Gentoo already.
local myeconfargs=(
--enable-uv
+ --enable-v0
+ --disable-backtrace
--disable-benchmark
--disable-debug
--disable-example
+ --disable-hardening
--disable-sanitize
--disable-static
- $(use_enable lz4)
$(use_enable test fixture)
+ $(use_with lz4)
$(use_with zfs)
)
diff --git a/dev-libs/raft/raft-0.22.1.ebuild b/dev-libs/raft/raft-0.22.1.ebuild
new file mode 100644
index 000000000000..39daa1268bef
--- /dev/null
+++ b/dev-libs/raft/raft-0.22.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C implementation of the Raft consensus protocol"
+HOMEPAGE="https://github.com/cowsql/raft"
+SRC_URI="https://github.com/cowsql/raft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+
+# Upstream change from canonical to cowsql resetted SONAME, 3 -> 0. bgo#915960
+SLOT="0/0"
+KEYWORDS="amd64 ~arm64 ~x86"
+IUSE="lz4 test zfs"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/libuv:=
+ lz4? ( app-arch/lz4:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/raft-0.10.0-toggle-zfs.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # --disable-hardening: most of these are covered on non-hardened Gentoo already.
+ local myeconfargs=(
+ --enable-uv
+ --enable-v0
+
+ --disable-backtrace
+ --disable-benchmark
+ --disable-debug
+ --disable-example
+ --disable-hardening
+ --disable-sanitize
+ --disable-static
+
+ $(use_enable test fixture)
+
+ $(use_with lz4)
+ $(use_with zfs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}