summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/rocm-device-libs/rocm-device-libs-5.7.0.ebuild')
-rw-r--r--dev-libs/rocm-device-libs/rocm-device-libs-5.7.0.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-libs/rocm-device-libs/rocm-device-libs-5.7.0.ebuild b/dev-libs/rocm-device-libs/rocm-device-libs-5.7.0.ebuild
deleted file mode 100644
index 56af5a5be6b3..000000000000
--- a/dev-libs/rocm-device-libs/rocm-device-libs-5.7.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake llvm
-
-LLVM_MAX_SLOT=17
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-Device-Libs/"
- inherit git-r3
- S="${WORKDIR}/${P}/src"
-else
- SRC_URI="https://github.com/RadeonOpenCompute/ROCm-Device-Libs/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/ROCm-Device-Libs-rocm-${PV}"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="Radeon Open Compute Device Libraries"
-HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-Device-Libs"
-
-LICENSE="MIT"
-SLOT="0/$(ver_cut 1-2)"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="sys-devel/clang:${LLVM_MAX_SLOT}"
-DEPEND="${RDEPEND}"
-
-CMAKE_BUILD_TYPE=Release
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.5.1-fix-llvm-link.patch"
- )
-
-src_prepare() {
- sed -e "s:amdgcn/bitcode:lib/amdgcn/bitcode:" -i "${S}/cmake/OCL.cmake" || die
- sed -e "s:amdgcn/bitcode:lib/amdgcn/bitcode:" -i "${S}/cmake/Packages.cmake" || die
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- # -DLLVM_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/llvm"
- -DLLVM_DIR="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
- )
- cmake_src_configure
-}