summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/serd/serd-0.30.8.ebuild')
-rw-r--r--dev-libs/serd/serd-0.30.8.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-libs/serd/serd-0.30.8.ebuild b/dev-libs/serd/serd-0.30.8.ebuild
deleted file mode 100644
index 4449d2045d4f..000000000000
--- a/dev-libs/serd/serd-0.30.8.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-PYTHON_REQ_USE='threads(+)'
-inherit python-any-r1 waf-utils multilib-build multilib-minimal
-
-DESCRIPTION="Library for RDF syntax which supports reading and writing Turtle and NTriples"
-HOMEPAGE="http://drobilla.net/software/serd/"
-SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc static-libs test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- doc? ( app-doc/doxygen )
-"
-RDEPEND=""
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
-"
-DOCS=( "AUTHORS" "NEWS" "README.md" )
-
-src_prepare() {
- sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
- default
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- waf-utils_src_configure \
- --docdir=/usr/share/doc/${PF} \
- $(multilib_native_usex doc --docs "") \
- $(usex test --test "") \
- $(usex static-libs --static "")
-}
-
-multilib_src_test() {
- ./waf test || die
-}
-
-multilib_src_compile() {
- waf-utils_src_compile
- default
-}
-
-multilib_src_install() {
- waf-utils_src_install
- default
-}