summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/simdjson/simdjson-0.4.7.ebuild')
-rw-r--r--dev-libs/simdjson/simdjson-0.4.7.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-libs/simdjson/simdjson-0.4.7.ebuild b/dev-libs/simdjson/simdjson-0.4.7.ebuild
deleted file mode 100644
index 77da37bac071..000000000000
--- a/dev-libs/simdjson/simdjson-0.4.7.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs cmake
-
-DESCRIPTION="SIMD accelerated C++ JSON library"
-HOMEPAGE="
- https://simdjson.org/
- https://github.com/simdjson/simdjson
-"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 Boost-1.0"
-SLOT="0/2"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-BDEPEND="
- sys-apps/file
- sys-apps/findutils
- sys-apps/grep
-"
-
-RESTRICT="!test? ( test )"
-
-src_configure() {
- local mycmakeargs=(
- $(usex test '' '-DSIMDJSON_JUST_LIBRARY=ON')
- )
-
- cmake_src_configure
-}