summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/skyutils/skyutils-2.8-r4.ebuild')
-rw-r--r--dev-libs/skyutils/skyutils-2.8-r4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/skyutils/skyutils-2.8-r4.ebuild b/dev-libs/skyutils/skyutils-2.8-r4.ebuild
new file mode 100644
index 000000000000..252add28bbd8
--- /dev/null
+++ b/dev-libs/skyutils/skyutils-2.8-r4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit flag-o-matic autotools
+
+DESCRIPTION="Library of assorted C utility functions"
+# Was: http://zekiller.skytech.org/coders_en.html
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libressl ssl sslv3"
+REQUIRED_USE="sslv3? ( ssl? ( !libressl ) )"
+
+DEPEND="ssl? (
+ !libressl? ( dev-libs/openssl:0=[sslv3?] )
+ libressl? ( dev-libs/libressl:0= )
+)"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-libs.patch"
+ "${FILESDIR}/fix-Wformat-security-warnings.patch"
+)
+
+src_prepare() {
+ default
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.in \
+ || die 'failed to rename AM_CONFIG_HEADER macro'
+
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -D_GNU_SOURCE
+ econf $(use_enable ssl)
+}