summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/softhsm/softhsm-2.5.0.ebuild')
-rw-r--r--dev-libs/softhsm/softhsm-2.5.0.ebuild31
1 files changed, 17 insertions, 14 deletions
diff --git a/dev-libs/softhsm/softhsm-2.5.0.ebuild b/dev-libs/softhsm/softhsm-2.5.0.ebuild
index c9d44cfbb66f..d9c6a91a08d5 100644
--- a/dev-libs/softhsm/softhsm-2.5.0.ebuild
+++ b/dev-libs/softhsm/softhsm-2.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,25 +7,27 @@ DESCRIPTION="A software PKCS#11 implementation"
HOMEPAGE="https://www.opendnssec.org/"
SRC_URI="https://www.opendnssec.org/files/source/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="bindist gost libressl migration-tool test"
+
RESTRICT="!test? ( test )"
-SLOT="2"
-LICENSE="BSD"
-RDEPEND="migration-tool? ( dev-db/sqlite:3= )
+RDEPEND="
+ migration-tool? ( dev-db/sqlite:3= )
!libressl? ( dev-libs/openssl:0=[bindist=] )
libressl? ( dev-libs/libressl:= )
- !~dev-libs/softhsm-2.0.0:0"
+ !~dev-libs/softhsm-2.0.0:0
+"
DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig
+BDEPEND="
sys-devel/gcc:=[cxx]
- test? ( dev-util/cppunit )"
+ virtual/pkgconfig
+ test? ( dev-util/cppunit )
+"
-DOCS=(
- NEWS
- README.md
-)
+DOCS=( NEWS README.md )
PATCHES=(
"${FILESDIR}/${P}-libressl.patch"
@@ -36,7 +38,7 @@ src_configure() {
--disable-static \
--with-crypto-backend=openssl \
--disable-p11-kit \
- --localstatedir="${EROOT}/var" \
+ --localstatedir="${EPREFIX}/var" \
$(use_enable !bindist ecc) \
$(use_enable gost) \
$(use_with migration-tool migrate)
@@ -44,7 +46,8 @@ src_configure() {
src_install() {
default
- find "${D}" -name '*.la' -delete || die
- keepdir "${EROOT}/var/lib/softhsm/tokens"
+ find "${ED}" -name '*.la' -delete || die
+
+ keepdir /var/lib/softhsm/tokens
}