summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/spdlog/spdlog-1.8.5-r1.ebuild')
-rw-r--r--dev-libs/spdlog/spdlog-1.8.5-r1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-libs/spdlog/spdlog-1.8.5-r1.ebuild b/dev-libs/spdlog/spdlog-1.8.5-r1.ebuild
deleted file mode 100644
index 26e7cb42bce4..000000000000
--- a/dev-libs/spdlog/spdlog-1.8.5-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Very fast, header only, C++ logging library"
-HOMEPAGE="https://github.com/gabime/spdlog"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/gabime/${PN}"
-else
- SRC_URI="https://github.com/gabime/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0/1"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- virtual/pkgconfig
-"
-DEPEND="
- >=dev-libs/libfmt-6.1.2:=
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-libfmt-8-fix.patch" )
-
-src_prepare() {
- cmake_src_prepare
- rm -r include/spdlog/fmt/bundled || die "Failed to delete bundled libfmt"
-}
-
-src_configure() {
- local mycmakeargs=(
- -DSPDLOG_BUILD_BENCH=no
- -DSPDLOG_BUILD_EXAMPLE=no
- -DSPDLOG_FMT_EXTERNAL=yes
- -DSPDLOG_BUILD_SHARED=yes
- -DSPDLOG_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}