summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.27.ebuild38
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-9999.ebuild4
3 files changed, 41 insertions, 2 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index 94adfe37bcce..c7dbbb71cd29 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1 +1,2 @@
DIST wayland-protocols-1.26.tar.xz 81028 BLAKE2B 0813b8117c48b965560c3f112f67fa209f29b0c40fab2b46f46ccae227d68902277cce06281a6bd938fb3c2186e0cf4ea3670ed6d3b48b51ed655012bb1452ce SHA512 fa9c3963b548197461c8c0b9e16ebbf9cfa5b60053fc17f51b41e63a55b8c5420dd7e42313f93946b438ab47f04e1cd17bc92aae9e1074b47177dc7ce7042167
+DIST wayland-protocols-1.27.tar.xz 82604 BLAKE2B ae1c19dffcf255c88e6d646f321ec194639500994f9e5a2759bd7081dc16872777c993d35d81000796e3e5044dc62f169c9b2fe89de081fd395eaaf09e6206e2 SHA512 c0a49bc46c663c9f602998dfe2e184c09756790fbcc7acbc2bf9d9cf8f7d6dcdd00259b768222a30e5d134e6f97f7f4faf252947b544e8b32f53278b70da0390
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.27.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.27.ebuild
new file mode 100644
index 000000000000..4eff41270cb0
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.27.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+RDEPEND=""
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
diff --git a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
index fd84b9649f01..4eff41270cb0 100644
--- a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
+++ b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
@@ -12,7 +12,7 @@ if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
inherit git-r3
else
- SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi