summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/Manifest1
-rw-r--r--dev-libs/wayland/wayland-1.14.0.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-libs/wayland/Manifest b/dev-libs/wayland/Manifest
index 529e1adbd85c..9e0aa19b30ea 100644
--- a/dev-libs/wayland/Manifest
+++ b/dev-libs/wayland/Manifest
@@ -1,2 +1 @@
-DIST wayland-1.14.0.tar.xz 413960 BLAKE2B b6d6bb35d3b664ef4cb91cbb9fc9687475730466306d9d2722991ce912be26fd4b3440fd0b94aba2b707911fe43a7c91e053b379261a17197c414ebc08818f83 SHA512 bd38b2b8963d4d98d42c270e5d7dbff6323789a173b19b67a18258424fd8adee5021b282c9d7f6dad0bd25aa0160e76aecd8ed803d4eb25d911ef0a81cd713a5
DIST wayland-1.15.0.tar.xz 432932 BLAKE2B d86e5ba52c16664926e4688317db3fad4f9629c3903239dde46ee238ef7874f28e39daa6bbda96519dfda4ff83a1f540522f21fbabe9b71aa263523481d4eb5b SHA512 f908917f1b575d2dc4d9770d3303e2637e8744fcb5c81feb2af2fe82cc51f54e22beaddfbe775fcf9623584169b7a062c75076132abeb888717180bfab53b3a8
diff --git a/dev-libs/wayland/wayland-1.14.0.ebuild b/dev-libs/wayland/wayland-1.14.0.ebuild
deleted file mode 100644
index 3ea948e26b83..000000000000
--- a/dev-libs/wayland/wayland-1.14.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland.git"
-
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-r3"
-fi
-
-inherit autotools libtool ltprune multilib-minimal toolchain-funcs $GIT_ECLASS
-
-DESCRIPTION="Wayland protocol libraries"
-HOMEPAGE="https://wayland.freedesktop.org/"
-
-if [[ $PV = 9999* ]]; then
- SRC_URI=""
-else
- SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
- KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc static-libs"
-
-RDEPEND=">=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
- >=virtual/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
- dev-libs/libxml2:="
-DEPEND="${RDEPEND}
- doc? (
- >=app-doc/doxygen-1.6[dot]
- app-text/xmlto
- >=media-gfx/graphviz-2.26.0
- sys-apps/grep[pcre]
- )
- virtual/pkgconfig"
-
-src_prepare() {
- default
- [[ $PV = 9999* ]] && eautoreconf || elibtoolize
-}
-
-multilib_src_configure() {
- local myconf
- if tc-is-cross-compiler ; then
- myconf+=' --with-host-scanner '
- fi
-
- ECONF_SOURCE="${S}" econf \
- --disable-static \
- $(multilib_native_use_enable doc documentation) \
- $(multilib_native_enable dtd-validation) \
- ${myconf}
-}
-
-multilib_src_install_all() {
- prune_libtool_files
- einstalldocs
-}
-
-src_test() {
- # We set it on purpose to only a short subdir name, as socket paths are
- # created in there, which are 108 byte limited. With this it hopefully
- # barely fits to the limit with /var/tmp/portage/$CAT/$PF/temp/xdr
- export XDG_RUNTIME_DIR="${T}"/xdr
- mkdir "${XDG_RUNTIME_DIR}" || die
- chmod 0700 "${XDG_RUNTIME_DIR}" || die
-
- multilib-minimal_src_test
-}