summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/wayland-9999.ebuild44
1 files changed, 28 insertions, 16 deletions
diff --git a/dev-libs/wayland/wayland-9999.ebuild b/dev-libs/wayland/wayland-9999.ebuild
index cb4da40703c5..2863cc6657ee 100644
--- a/dev-libs/wayland/wayland-9999.ebuild
+++ b/dev-libs/wayland/wayland-9999.ebuild
@@ -1,23 +1,21 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
GIT_ECLASS="git-r3"
- EXPERIMENTAL="true"
- AUTOTOOLS_AUTORECONF=1
fi
-inherit autotools-multilib toolchain-funcs $GIT_ECLASS
+inherit autotools libtool ltprune multilib-minimal toolchain-funcs $GIT_ECLASS
DESCRIPTION="Wayland protocol libraries"
HOMEPAGE="https://wayland.freedesktop.org/"
if [[ $PV = 9999* ]]; then
- SRC_URI="${SRC_PATCHES}"
- KEYWORDS=""
+ SRC_URI=""
else
SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
@@ -39,22 +37,36 @@ DEPEND="${RDEPEND}
)
virtual/pkgconfig"
+src_prepare() {
+ default
+ [[ $PV = 9999* ]] && eautoreconf || elibtoolize
+}
+
multilib_src_configure() {
- local myeconfargs=(
- $(multilib_native_use_enable doc documentation)
- $(multilib_native_enable dtd-validation)
- )
+ local myconf
if tc-is-cross-compiler ; then
- myeconfargs+=( --with-host-scanner )
+ myconf+=' --with-host-scanner '
fi
- autotools-utils_src_configure
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ $(multilib_native_use_enable doc documentation) \
+ $(multilib_native_enable dtd-validation) \
+ ${myconf}
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ einstalldocs
}
src_test() {
- export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ # We set it on purpose to only a short subdir name, as socket paths are
+ # created in there, which are 108 byte limited. With this it hopefully
+ # barely fits to the limit with /var/tmp/portage/$CAT/$PF/temp/xdr
+ export XDG_RUNTIME_DIR="${T}"/xdr
mkdir "${XDG_RUNTIME_DIR}" || die
chmod 0700 "${XDG_RUNTIME_DIR}" || die
- autotools-multilib_src_test
+ multilib-minimal_src_test
}