summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/xxhash/xxhash-0.6.5.ebuild')
-rw-r--r--dev-libs/xxhash/xxhash-0.6.5.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-libs/xxhash/xxhash-0.6.5.ebuild b/dev-libs/xxhash/xxhash-0.6.5.ebuild
index 2b31be40a067..f23c18c478a8 100644
--- a/dev-libs/xxhash/xxhash-0.6.5.ebuild
+++ b/dev-libs/xxhash/xxhash-0.6.5.ebuild
@@ -2,8 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Extremely fast non-cryptographic hash algorithm"
HOMEPAGE="http://www.xxhash.com"
@@ -11,13 +10,17 @@ SRC_URI="https://github.com/Cyan4973/xxHash/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="BSD-2 GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x64-macos"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x64-macos"
IUSE="static-libs"
DEPEND=""
S="${WORKDIR}/xxHash-${PV}"
+src_configure() {
+ use hppa && replace-flags '-O*' '-O0'
+}
+
src_compile() {
PREFIX="${EPREFIX}/usr" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)" \