summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.26.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index fa9d4bb5a5e3..35ceab34ce3a 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1 +1,2 @@
DIST wayland-protocols-1.25.tar.xz 79784 BLAKE2B 6ca7fdc910bfd70ee5c3bb192bcf1c79c66c4bb713531b2d1d493bd3ec8509e1231176144d75f4e97a4c6ccc4ee1d836a7ac1cfeaaa59e927f10fa4a40cf023a SHA512 8269694a0780e4d32f1982ff4cbb50b1ef85f08157b9486bc6d7e489c64665a9d9f959121d0eede7c7b108a604d974b64d74cfdef8b5f14304465309afb0768f
+DIST wayland-protocols-1.26.tar.xz 81028 BLAKE2B 0813b8117c48b965560c3f112f67fa209f29b0c40fab2b46f46ccae227d68902277cce06281a6bd938fb3c2186e0cf4ea3670ed6d3b48b51ed655012bb1452ce SHA512 fa9c3963b548197461c8c0b9e16ebbf9cfa5b60053fc17f51b41e63a55b8c5420dd7e42313f93946b438ab47f04e1cd17bc92aae9e1074b47177dc7ce7042167
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.26.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.26.ebuild
new file mode 100644
index 000000000000..fd84b9649f01
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.26.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+RDEPEND=""
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}