summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/rocm-comgr/files/rocm-comgr-4.3.0_strip-usr-include.patch16
-rw-r--r--dev-libs/rocm-comgr/rocm-comgr-4.3.0-r1.ebuild39
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/rocm-comgr/files/rocm-comgr-4.3.0_strip-usr-include.patch b/dev-libs/rocm-comgr/files/rocm-comgr-4.3.0_strip-usr-include.patch
new file mode 100644
index 000000000000..9d722a57d2a6
--- /dev/null
+++ b/dev-libs/rocm-comgr/files/rocm-comgr-4.3.0_strip-usr-include.patch
@@ -0,0 +1,16 @@
+On Gentoo, ROCM_PATH=/usr we do not need to set -I${ROCM_PATH}/include.
+Actually it is harmful to the `include_next`s.
+
+Index: ROCm-CompilerSupport-rocm-4.3.0/lib/comgr/src/comgr-compiler.cpp
+===================================================================
+--- comgr/src/comgr-compiler.cpp
++++ comgr/src/comgr-compiler.cpp
+@@ -927,8 +927,6 @@ AMDGPUCompiler::addTargetIdentifierFlags
+
+ amd_comgr_status_t AMDGPUCompiler::addCompilationFlags() {
+ HIPIncludePath = (Twine(env::getHIPPath()) + "/include").str();
+- // HIP headers depend on hsa.h which is in ROCM_DIR/include.
+- ROCMIncludePath = (Twine(env::getROCMPath()) + "/include").str();
+ ClangIncludePath =
+ (Twine(env::getLLVMPath()) + "/lib/clang/" + CLANG_VERSION_STRING).str();
+ ClangIncludePath2 = (Twine(env::getLLVMPath()) + "/lib/clang/" +
diff --git a/dev-libs/rocm-comgr/rocm-comgr-4.3.0-r1.ebuild b/dev-libs/rocm-comgr/rocm-comgr-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..192ddca854e1
--- /dev/null
+++ b/dev-libs/rocm-comgr/rocm-comgr-4.3.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/lib/comgr"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCm-CompilerSupport-rocm-${PV}/lib/comgr"
+ KEYWORDS="~amd64"
+fi
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.0-dependencies.patch
+ "${FILESDIR}"/${PN}-4.3.0_strip-usr-include.patch
+)
+
+DESCRIPTION="Radeon Open Compute Code Object Manager"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND=">=dev-libs/rocm-device-libs-${PV}
+ >=sys-devel/llvm-roc-${PV}:="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLLD_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/lld"
+ -DLLVM_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/llvm"
+ -DClang_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/clang"
+ )
+ cmake_src_configure
+}