summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/elfutils/Manifest2
-rw-r--r--dev-libs/elfutils/elfutils-0.170-r1.ebuild66
-rw-r--r--dev-libs/elfutils/elfutils-0.173-r1.ebuild70
-rw-r--r--dev-libs/elfutils/elfutils-0.173-r2.ebuild71
-rw-r--r--dev-libs/elfutils/elfutils-0.176.ebuild70
-rw-r--r--dev-libs/elfutils/files/elfutils-0.173-partial-core.patch34
6 files changed, 0 insertions, 313 deletions
diff --git a/dev-libs/elfutils/Manifest b/dev-libs/elfutils/Manifest
index 29c6e6f4865a..b8b07d4c8982 100644
--- a/dev-libs/elfutils/Manifest
+++ b/dev-libs/elfutils/Manifest
@@ -1,3 +1 @@
-DIST elfutils-0.170.tar.bz2 8358001 BLAKE2B 03ea3ba7d3feaac43065312c475f4a3cd9083a6c56c9982fa00c0ed02b28440f6a37bbeca4be18db13749647ea1c8a6f00dae7efcb1c70235110e60ad7d56d06 SHA512 aca0b5e271138eaf86e36505ffb101181207b151e833e6cd7c18986ac50678542a5ecd2250f8dd6923ca497142f197c8b08fd225e4130b16b6203c24013d6d28
-DIST elfutils-0.173.tar.bz2 8684782 BLAKE2B c5905bb864059bdfb2699a0681a0ec576b6b8da444b0641e8184f58735084588910930bcca14583db6be75b24a0e374413911ded5ba2ca893798404fbe7374eb SHA512 7f38e4ce2098b685f15030bf01f0a66a74aa32fbfcead0304c1d0e0a929b348a72f99e685cd4605465f4337393382112f64b8847e6c2f7cc1a57a4fd03d03eb3
DIST elfutils-0.176.tar.bz2 8646075 BLAKE2B 7f23d59b7f5d74946fea928a7fada7764c1f96a5eefefc4a3a382090eb7cad07c80419218300d853ccbef8f4e2288eb443ff06b3e64bf4511d9fa7aa84f5b794 SHA512 7f032913be363a43229ded85d495dcf7542b3c85974aaaba0d984228dc9ac1721da3dc388d3fa02325a80940161db7e9ad2c9e4521a424ad8a7d050c0902915b
diff --git a/dev-libs/elfutils/elfutils-0.170-r1.ebuild b/dev-libs/elfutils/elfutils-0.170-r1.ebuild
deleted file mode 100644
index 43f88abea483..000000000000
--- a/dev-libs/elfutils/elfutils-0.170-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic multilib-minimal
-
-DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
-HOMEPAGE="http://elfutils.org/"
-SRC_URI="https://sourceware.org/elfutils/ftp/${PV}/${P}.tar.bz2"
-
-LICENSE="|| ( GPL-2+ LGPL-3+ ) utils? ( GPL-3+ )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 lzma nls static-libs test +threads +utils"
-
-RDEPEND=">=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
- bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
- lzma? ( >=app-arch/xz-utils-5.0.5-r1[${MULTILIB_USEDEP}] )
- !dev-libs/libelf"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- >=sys-devel/flex-2.5.4a
- sys-devel/m4"
-
-PATCHES=("${FILESDIR}"/${PN}-0.118-PaX-support.patch)
-
-src_prepare() {
- default
-
- if ! use static-libs; then
- sed -i -e '/^lib_LIBRARIES/s:=.*:=:' -e '/^%.os/s:%.o$::' lib{asm,dw,elf}/Makefile.in || die
- fi
- sed -i 's:-Werror::' */Makefile.in || die
-}
-
-src_configure() {
- use test && append-flags -g #407135
- multilib-minimal_src_configure
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable nls) \
- $(use_enable threads thread-safety) \
- --program-prefix="eu-" \
- --with-zlib \
- $(use_with bzip2 bzlib) \
- $(use_with lzma)
-}
-
-multilib_src_test() {
- env LD_LIBRARY_PATH="${BUILD_DIR}/libelf:${BUILD_DIR}/libebl:${BUILD_DIR}/libdw:${BUILD_DIR}/libasm" \
- LC_ALL="C" \
- emake check
-}
-
-multilib_src_install_all() {
- einstalldocs
- dodoc NOTES
- # These build quick, and are needed for most tests, so don't
- # disable their building when the USE flag is disabled.
- if ! use utils; then
- rm -rf "${ED}"/usr/bin || die
- fi
-}
diff --git a/dev-libs/elfutils/elfutils-0.173-r1.ebuild b/dev-libs/elfutils/elfutils-0.173-r1.ebuild
deleted file mode 100644
index d102c9265db0..000000000000
--- a/dev-libs/elfutils/elfutils-0.173-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic multilib-minimal
-
-DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
-HOMEPAGE="http://elfutils.org/"
-SRC_URI="https://sourceware.org/elfutils/ftp/${PV}/${P}.tar.bz2"
-
-LICENSE="|| ( GPL-2+ LGPL-3+ ) utils? ( GPL-3+ )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 lzma nls static-libs test +threads +utils"
-
-RDEPEND=">=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
- bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
- lzma? ( >=app-arch/xz-utils-5.0.5-r1[${MULTILIB_USEDEP}] )
- !dev-libs/libelf"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- >=sys-devel/flex-2.5.4a
- sys-devel/m4"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.118-PaX-support.patch
- "${FILESDIR}"/${PN}-0.173-partial-core.patch
- "${FILESDIR}"/${PN}-0.175-disable-biarch-test-PR24158.patch
-)
-
-src_prepare() {
- default
-
- if ! use static-libs; then
- sed -i -e '/^lib_LIBRARIES/s:=.*:=:' -e '/^%.os/s:%.o$::' lib{asm,dw,elf}/Makefile.in || die
- fi
- sed -i 's:-Werror::' */Makefile.in || die
-}
-
-src_configure() {
- use test && append-flags -g #407135
- multilib-minimal_src_configure
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable nls) \
- $(use_enable threads thread-safety) \
- --program-prefix="eu-" \
- --with-zlib \
- $(use_with bzip2 bzlib) \
- $(use_with lzma)
-}
-
-multilib_src_test() {
- env LD_LIBRARY_PATH="${BUILD_DIR}/libelf:${BUILD_DIR}/libebl:${BUILD_DIR}/libdw:${BUILD_DIR}/libasm" \
- LC_ALL="C" \
- emake check VERBOSE=1
-}
-
-multilib_src_install_all() {
- einstalldocs
- dodoc NOTES
- # These build quick, and are needed for most tests, so don't
- # disable their building when the USE flag is disabled.
- if ! use utils; then
- rm -rf "${ED}"/usr/bin || die
- fi
-}
diff --git a/dev-libs/elfutils/elfutils-0.173-r2.ebuild b/dev-libs/elfutils/elfutils-0.173-r2.ebuild
deleted file mode 100644
index 668001589b8e..000000000000
--- a/dev-libs/elfutils/elfutils-0.173-r2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic multilib-minimal
-
-DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
-HOMEPAGE="http://elfutils.org/"
-SRC_URI="https://sourceware.org/elfutils/ftp/${PV}/${P}.tar.bz2"
-
-LICENSE="|| ( GPL-2+ LGPL-3+ ) utils? ( GPL-3+ )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 lzma nls static-libs test +threads +utils"
-
-RDEPEND=">=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
- bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
- lzma? ( >=app-arch/xz-utils-5.0.5-r1[${MULTILIB_USEDEP}] )
- !dev-libs/libelf"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- >=sys-devel/flex-2.5.4a
- sys-devel/m4"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.118-PaX-support.patch
- "${FILESDIR}"/${PN}-0.173-partial-core.patch
- "${FILESDIR}"/${PN}-0.175-disable-biarch-test-PR24158.patch
- "${FILESDIR}"/${PN}-0.173-reorder.patch
-)
-
-src_prepare() {
- default
-
- if ! use static-libs; then
- sed -i -e '/^lib_LIBRARIES/s:=.*:=:' -e '/^%.os/s:%.o$::' lib{asm,dw,elf}/Makefile.in || die
- fi
- sed -i 's:-Werror::' */Makefile.in || die
-}
-
-src_configure() {
- use test && append-flags -g #407135
- multilib-minimal_src_configure
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable nls) \
- $(use_enable threads thread-safety) \
- --program-prefix="eu-" \
- --with-zlib \
- $(use_with bzip2 bzlib) \
- $(use_with lzma)
-}
-
-multilib_src_test() {
- env LD_LIBRARY_PATH="${BUILD_DIR}/libelf:${BUILD_DIR}/libebl:${BUILD_DIR}/libdw:${BUILD_DIR}/libasm" \
- LC_ALL="C" \
- emake check VERBOSE=1
-}
-
-multilib_src_install_all() {
- einstalldocs
- dodoc NOTES
- # These build quick, and are needed for most tests, so don't
- # disable their building when the USE flag is disabled.
- if ! use utils; then
- rm -rf "${ED}"/usr/bin || die
- fi
-}
diff --git a/dev-libs/elfutils/elfutils-0.176.ebuild b/dev-libs/elfutils/elfutils-0.176.ebuild
deleted file mode 100644
index e8dd597d47f2..000000000000
--- a/dev-libs/elfutils/elfutils-0.176.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic multilib-minimal
-
-DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
-HOMEPAGE="http://elfutils.org/"
-SRC_URI="https://sourceware.org/elfutils/ftp/${PV}/${P}.tar.bz2"
-
-LICENSE="|| ( GPL-2+ LGPL-3+ ) utils? ( GPL-3+ )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 lzma nls static-libs test +threads +utils"
-
-RDEPEND=">=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
- bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
- lzma? ( >=app-arch/xz-utils-5.0.5-r1[${MULTILIB_USEDEP}] )
- !dev-libs/libelf"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- >=sys-devel/flex-2.5.4a
- sys-devel/m4"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.118-PaX-support.patch
- "${FILESDIR}"/${PN}-0.175-disable-biarch-test-PR24158.patch
-)
-
-src_prepare() {
- default
-
- if ! use static-libs; then
- sed -i -e '/^lib_LIBRARIES/s:=.*:=:' -e '/^%.os/s:%.o$::' lib{asm,dw,elf}/Makefile.in || die
- fi
- # https://sourceware.org/PR23914
- sed -i 's:-Werror::' */Makefile.in || die
-}
-
-src_configure() {
- use test && append-flags -g #407135
- multilib-minimal_src_configure
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable nls) \
- $(use_enable threads thread-safety) \
- --program-prefix="eu-" \
- --with-zlib \
- $(use_with bzip2 bzlib) \
- $(use_with lzma)
-}
-
-multilib_src_test() {
- env LD_LIBRARY_PATH="${BUILD_DIR}/libelf:${BUILD_DIR}/libebl:${BUILD_DIR}/libdw:${BUILD_DIR}/libasm" \
- LC_ALL="C" \
- emake check VERBOSE=1
-}
-
-multilib_src_install_all() {
- einstalldocs
- dodoc NOTES
- # These build quick, and are needed for most tests, so don't
- # disable their building when the USE flag is disabled.
- if ! use utils; then
- rm -rf "${ED}"/usr/bin || die
- fi
-}
diff --git a/dev-libs/elfutils/files/elfutils-0.173-partial-core.patch b/dev-libs/elfutils/files/elfutils-0.173-partial-core.patch
deleted file mode 100644
index 41ef14d66838..000000000000
--- a/dev-libs/elfutils/files/elfutils-0.173-partial-core.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-https://sourceware.org/PR24103
-https://bugs.gentoo.org/676794
-
-From da5c5336a1eaf519de246f7d9f0f5585e1d4ac59 Mon Sep 17 00:00:00 2001
-From: Mark Wielaard <mark@klomp.org>
-Date: Sun, 20 Jan 2019 23:05:56 +0100
-Subject: [PATCH] libdwfl: Sanity check partial core file dyn data read.
-
-When reading the dyn data from the core file check if we got everything,
-or just part of the data.
-
-https://sourceware.org/bugzilla/show_bug.cgi?id=24103
-
-Signed-off-by: Mark Wielaard <mark@klomp.org>
----
- libdwfl/dwfl_segment_report_module.c | 6 ++++++
-
---- a/libdwfl/dwfl_segment_report_module.c
-+++ b/libdwfl/dwfl_segment_report_module.c
-@@ -783,6 +783,12 @@ dwfl_segment_report_module (Dwfl *dwfl, int ndx, const char *name,
- if (dyn_filesz != 0 && dyn_filesz % dyn_entsize == 0
- && ! read_portion (&dyn_data, &dyn_data_size, dyn_vaddr, dyn_filesz))
- {
-+ /* dyn_data_size will be zero if we got everything from the initial
-+ buffer, otherwise it will be the size of the new buffer that
-+ could be read. */
-+ if (dyn_data_size != 0)
-+ dyn_filesz = dyn_data_size;
-+
- void *dyns = malloc (dyn_filesz);
- Elf32_Dyn (*d32)[dyn_filesz / sizeof (Elf32_Dyn)] = dyns;
- Elf64_Dyn (*d64)[dyn_filesz / sizeof (Elf64_Dyn)] = dyns;
---
-2.20.1