summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/check/check-0.10.0-r1.ebuild1
-rw-r--r--dev-libs/check/check-0.12.0.ebuild1
-rw-r--r--dev-libs/check/check-0.14.0.ebuild1
-rw-r--r--dev-libs/cxxtools/cxxtools-2.2.1.ebuild1
-rw-r--r--dev-libs/libgcrypt-compat/libgcrypt-compat-1.5.6.ebuild3
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.8.3-r1.ebuild3
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.8.3.ebuild1
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.8.4.ebuild3
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.8.5.ebuild1
-rw-r--r--dev-libs/libindicate/libindicate-12.10.1-r3.ebuild1
-rw-r--r--dev-libs/libindicator/libindicator-12.10.1-r201.ebuild1
-rw-r--r--dev-libs/libindicator/libindicator-12.10.1-r301.ebuild1
-rw-r--r--dev-libs/libmodbus/libmodbus-3.1.4.ebuild3
-rw-r--r--dev-libs/libnl/libnl-3.4.0.ebuild3
-rw-r--r--dev-libs/libnl/libnl-3.5.0.ebuild3
-rw-r--r--dev-libs/libnl/libnl-99999999.ebuild3
-rw-r--r--dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild1
-rw-r--r--dev-libs/opencryptoki/opencryptoki-3.4.1.ebuild3
-rw-r--r--dev-libs/opencryptoki/opencryptoki-3.6.1.ebuild3
-rw-r--r--dev-libs/popt/popt-1.16-r2.ebuild1
20 files changed, 9 insertions, 29 deletions
diff --git a/dev-libs/check/check-0.10.0-r1.ebuild b/dev-libs/check/check-0.10.0-r1.ebuild
index 7ff7e07cf87f..5ebd3f07b8cb 100644
--- a/dev-libs/check/check-0.10.0-r1.ebuild
+++ b/dev-libs/check/check-0.10.0-r1.ebuild
@@ -43,7 +43,6 @@ src_prepare() {
src_configure() {
local myeconfargs=(
- --disable-dependency-tracking
$(use_enable subunit)
--docdir="${EPREFIX}/usr/share/doc/${PF}"
)
diff --git a/dev-libs/check/check-0.12.0.ebuild b/dev-libs/check/check-0.12.0.ebuild
index d7156aabdd46..5650c9493137 100644
--- a/dev-libs/check/check-0.12.0.ebuild
+++ b/dev-libs/check/check-0.12.0.ebuild
@@ -45,7 +45,6 @@ src_prepare() {
multilib_src_configure() {
local myeconfargs=(
- --disable-dependency-tracking
$(use_enable subunit)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
diff --git a/dev-libs/check/check-0.14.0.ebuild b/dev-libs/check/check-0.14.0.ebuild
index c1de319b23d4..4523528ee3e3 100644
--- a/dev-libs/check/check-0.14.0.ebuild
+++ b/dev-libs/check/check-0.14.0.ebuild
@@ -33,7 +33,6 @@ src_prepare() {
multilib_src_configure() {
local myeconfargs=(
- --disable-dependency-tracking
$(use_enable doc build-docs)
$(use_enable subunit)
$(use_enable test timeout-tests)
diff --git a/dev-libs/cxxtools/cxxtools-2.2.1.ebuild b/dev-libs/cxxtools/cxxtools-2.2.1.ebuild
index 073a9fc92cfb..70a5b32243c0 100644
--- a/dev-libs/cxxtools/cxxtools-2.2.1.ebuild
+++ b/dev-libs/cxxtools/cxxtools-2.2.1.ebuild
@@ -17,7 +17,6 @@ DEPEND="${RDEPEND}"
src_configure() {
econf \
- --disable-dependency-tracking \
--disable-demos \
--disable-unittest
}
diff --git a/dev-libs/libgcrypt-compat/libgcrypt-compat-1.5.6.ebuild b/dev-libs/libgcrypt-compat/libgcrypt-compat-1.5.6.ebuild
index bca8a3b5d9a2..a52e734e1836 100644
--- a/dev-libs/libgcrypt-compat/libgcrypt-compat-1.5.6.ebuild
+++ b/dev-libs/libgcrypt-compat/libgcrypt-compat-1.5.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -36,7 +36,6 @@ src_prepare() {
multilib_src_configure() {
local myeconfargs=(
--disable-padlock-support # bug 201917
- --disable-dependency-tracking
--enable-noexecstack
--disable-O-flag-munging
diff --git a/dev-libs/libgcrypt/libgcrypt-1.8.3-r1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.8.3-r1.ebuild
index 22ba9221713d..5821d4f4f907 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.8.3-r1.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.8.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -40,7 +40,6 @@ multilib_src_configure() {
append-cflags -Wa,--divide
fi
local myeconfargs=(
- --disable-dependency-tracking
--enable-noexecstack
$(use_enable o-flag-munging O-flag-munging)
$(use_enable static-libs static)
diff --git a/dev-libs/libgcrypt/libgcrypt-1.8.3.ebuild b/dev-libs/libgcrypt/libgcrypt-1.8.3.ebuild
index c233727259ac..9421ee98f643 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.8.3.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.8.3.ebuild
@@ -40,7 +40,6 @@ multilib_src_configure() {
append-cflags -Wa,--divide
fi
local myeconfargs=(
- --disable-dependency-tracking
--enable-noexecstack
$(use_enable o-flag-munging O-flag-munging)
$(use_enable static-libs static)
diff --git a/dev-libs/libgcrypt/libgcrypt-1.8.4.ebuild b/dev-libs/libgcrypt/libgcrypt-1.8.4.ebuild
index 778b99687913..b3008df69b14 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.8.4.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.8.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -40,7 +40,6 @@ multilib_src_configure() {
append-cflags -Wa,--divide
fi
local myeconfargs=(
- --disable-dependency-tracking
--enable-noexecstack
$(use_enable o-flag-munging O-flag-munging)
$(use_enable static-libs static)
diff --git a/dev-libs/libgcrypt/libgcrypt-1.8.5.ebuild b/dev-libs/libgcrypt/libgcrypt-1.8.5.ebuild
index 2aa47e6fcf9a..1a36bd5e114d 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.8.5.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.8.5.ebuild
@@ -40,7 +40,6 @@ multilib_src_configure() {
append-cflags -Wa,--divide
fi
local myeconfargs=(
- --disable-dependency-tracking
--enable-noexecstack
$(use_enable o-flag-munging O-flag-munging)
$(use_enable static-libs static)
diff --git a/dev-libs/libindicate/libindicate-12.10.1-r3.ebuild b/dev-libs/libindicate/libindicate-12.10.1-r3.ebuild
index 5eb278f4e4b7..b3d10dacf948 100644
--- a/dev-libs/libindicate/libindicate-12.10.1-r3.ebuild
+++ b/dev-libs/libindicate/libindicate-12.10.1-r3.ebuild
@@ -60,7 +60,6 @@ src_configure() {
# python bindings are only for GTK+-2.x
econf \
- --disable-silent-rules \
--disable-static \
$(use_enable gtk) \
$(use_enable introspection) \
diff --git a/dev-libs/libindicator/libindicator-12.10.1-r201.ebuild b/dev-libs/libindicator/libindicator-12.10.1-r201.ebuild
index e3d8f80f60b2..8e59ad01fd19 100644
--- a/dev-libs/libindicator/libindicator-12.10.1-r201.ebuild
+++ b/dev-libs/libindicator/libindicator-12.10.1-r201.ebuild
@@ -30,7 +30,6 @@ multilib_src_configure() {
append-flags -Wno-error
myconf=(
- --disable-silent-rules
--disable-static
--with-gtk=2
)
diff --git a/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild b/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild
index 04bb88e316ba..7dbbe27af996 100644
--- a/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild
+++ b/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild
@@ -31,7 +31,6 @@ multilib_src_configure() {
append-flags -Wno-error
myconf=(
- --disable-silent-rules
--disable-static
--with-gtk=3
)
diff --git a/dev-libs/libmodbus/libmodbus-3.1.4.ebuild b/dev-libs/libmodbus/libmodbus-3.1.4.ebuild
index b8b3f359a002..5592a4bbd211 100644
--- a/dev-libs/libmodbus/libmodbus-3.1.4.ebuild
+++ b/dev-libs/libmodbus/libmodbus-3.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,7 +21,6 @@ PATCHES=( "${FILESDIR}"/${P}-doc.patch )
src_configure() {
econf \
- --disable-silent-rules \
$(use_enable test tests) \
$(use_enable static-libs static) \
$(use_with doc documentation)
diff --git a/dev-libs/libnl/libnl-3.4.0.ebuild b/dev-libs/libnl/libnl-3.4.0.ebuild
index 04fc2e4dabe6..5d321fe6abf3 100644
--- a/dev-libs/libnl/libnl-3.4.0.ebuild
+++ b/dev-libs/libnl/libnl-3.4.0.ebuild
@@ -74,8 +74,7 @@ multilib_src_configure() {
$(multilib_native_use_enable utils cli) \
$(use_enable debug) \
$(use_enable static-libs static) \
- $(use_enable threads) \
- --disable-silent-rules
+ $(use_enable threads)
}
multilib_src_compile() {
diff --git a/dev-libs/libnl/libnl-3.5.0.ebuild b/dev-libs/libnl/libnl-3.5.0.ebuild
index 28138672f5b2..be977647afa1 100644
--- a/dev-libs/libnl/libnl-3.5.0.ebuild
+++ b/dev-libs/libnl/libnl-3.5.0.ebuild
@@ -75,8 +75,7 @@ multilib_src_configure() {
$(multilib_native_use_enable utils cli) \
$(use_enable debug) \
$(use_enable static-libs static) \
- $(use_enable threads) \
- --disable-silent-rules
+ $(use_enable threads)
}
multilib_src_compile() {
diff --git a/dev-libs/libnl/libnl-99999999.ebuild b/dev-libs/libnl/libnl-99999999.ebuild
index 9a6a52092d76..bbdb3529b765 100644
--- a/dev-libs/libnl/libnl-99999999.ebuild
+++ b/dev-libs/libnl/libnl-99999999.ebuild
@@ -69,8 +69,7 @@ multilib_src_configure() {
$(multilib_native_use_enable utils cli) \
$(use_enable debug) \
$(use_enable static-libs static) \
- $(use_enable threads) \
- --disable-silent-rules
+ $(use_enable threads)
}
multilib_src_compile() {
diff --git a/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild b/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild
index c52589ef574f..f7055c8310b2 100644
--- a/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild
+++ b/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild
@@ -26,7 +26,6 @@ src_prepare() {
src_configure() {
econf \
- --disable-dependency-tracking \
$(use_enable static-libs static) \
$(use_enable doc doxygen-html)
}
diff --git a/dev-libs/opencryptoki/opencryptoki-3.4.1.ebuild b/dev-libs/opencryptoki/opencryptoki-3.4.1.ebuild
index da43888b4524..99428ccb4f77 100644
--- a/dev-libs/opencryptoki/opencryptoki-3.4.1.ebuild
+++ b/dev-libs/opencryptoki/opencryptoki-3.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -63,7 +63,6 @@ src_configure() {
econf \
--localstatedir=/var \
--enable-fast-install \
- --disable-dependency-tracking \
--disable-debug \
--enable-daemon \
--enable-library \
diff --git a/dev-libs/opencryptoki/opencryptoki-3.6.1.ebuild b/dev-libs/opencryptoki/opencryptoki-3.6.1.ebuild
index 35d8afef5833..f3666b16096e 100644
--- a/dev-libs/opencryptoki/opencryptoki-3.6.1.ebuild
+++ b/dev-libs/opencryptoki/opencryptoki-3.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -63,7 +63,6 @@ src_configure() {
econf \
--localstatedir=/var \
--enable-fast-install \
- --disable-dependency-tracking \
--disable-debug \
--enable-daemon \
--enable-library \
diff --git a/dev-libs/popt/popt-1.16-r2.ebuild b/dev-libs/popt/popt-1.16-r2.ebuild
index 1c1080243583..d3f03ec51fe2 100644
--- a/dev-libs/popt/popt-1.16-r2.ebuild
+++ b/dev-libs/popt/popt-1.16-r2.ebuild
@@ -25,7 +25,6 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE=${S} \
econf \
- --disable-dependency-tracking \
$(use_enable static-libs static) \
$(use_enable nls)
}