summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cdk/Manifest2
-rw-r--r--dev-libs/cdk/cdk-5.0.20221025.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/cdk/Manifest b/dev-libs/cdk/Manifest
index 922f35793fb8..a69033cc63bc 100644
--- a/dev-libs/cdk/Manifest
+++ b/dev-libs/cdk/Manifest
@@ -1,2 +1,4 @@
DIST cdk-5.0-20210324.tgz 548203 BLAKE2B 7a944f347bf30a6bf602b9ac61fa547c7b4aef073db54272e4a8d2bd7d83093888f2ca9e5ee9c2d067777472d2abb87cca42b2912b0491b81472cfce086640b8 SHA512 72d62307824708858ca4fb3865d332cc81e987d7ef685011cf127c8f77cee3e19fe9dd6a35009d4416769cb00f04e937ebaec686c61ca0ba58655f522a175a59
DIST cdk-5.0-20211216.tgz 552041 BLAKE2B ce82ac22d4ec2ed37079d3de52a4f93a4206e5228aa952a3e45294d260c1ffef7c363b2c290060cc909bb8ab4ae88cbedecf498db7bd0f13e2d2822d87d7e4fa SHA512 622e99681af8468aaf8638833d0821c743667fb9b41716fe16acb8e78e8a3d5ba4eb7aced0bc213697e120dcb6e96067d6b75d53531555c3e6d90e4961cb99aa
+DIST cdk-5.0-20221025.tgz 540925 BLAKE2B 48b37d07630bc71fc5b1a77fa2732c264e61323fc00c60db1436403db46bfc4f870fa897560b705583b07db84b8f812df553780f4bddef4ca88de6b799c31f57 SHA512 408ab61f8110c13d32976896e92f8ded4927eac36435bce6d9fafbe137e693779ffd882829712086868766a252e35e6c592da69c43cfb32d9f4cf7e880c2a593
+DIST cdk-5.0-20221025.tgz.asc 729 BLAKE2B 0e6d0fdfcdb7e8a2139b5050cd2ff79f493edb67a0119baf5b009a00ea9fe715bb85da7980f35dbf688462b8dc07fc1e630101b072111fc626696bb90d318dc8 SHA512 66c52ac973fa6c133ae5a76b1661980b6a32144854c518f9bcddce8bd0b28e60167f8e09f87b99bff59e996275b3844f2c1c4b20d0a40a784700f53394fcbbcc
diff --git a/dev-libs/cdk/cdk-5.0.20221025.ebuild b/dev-libs/cdk/cdk-5.0.20221025.ebuild
new file mode 100644
index 000000000000..c974d478f4bd
--- /dev/null
+++ b/dev-libs/cdk/cdk-5.0.20221025.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}-$(ver_rs 2 -)"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+DESCRIPTION="A library of curses widgets"
+HOMEPAGE="https://dickey.his.com/cdk/cdk.html https://github.com/ThomasDickey/cdk-snapshots"
+SRC_URI="https://invisible-island.net/archives/${PN}/${MY_P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${MY_P}.tgz.asc )"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0/6" # subslot = soname version
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="examples unicode"
+
+DEPEND="sys-libs/ncurses:=[unicode(+)?]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
+"
+
+src_configure() {
+ if [[ ${CHOST} == *-*-darwin* ]] ; then
+ export ac_cv_prog_LIBTOOL=glibtool
+ fi
+
+ # --with-libtool dropped for now because of broken Makefile
+ # bug #790773
+ econf \
+ --disable-rpath-hack \
+ --with-shared \
+ --with-pkg-config \
+ --with-ncurses$(usex unicode "w" "")
+}
+
+src_install() {
+ # parallel make installs duplicate libs
+ emake -j1 \
+ DESTDIR="${D}" \
+ DOCUMENT_DIR="${ED}/usr/share/doc/${PF}" \
+ install
+
+ if use examples ; then
+ local x
+ for x in include c++ demos examples cli cli/utils cli/samples ; do
+ docinto ${x}
+ find ${x} -maxdepth 1 -mindepth 1 -type f -print0 | xargs -0 dodoc || die
+ done
+ fi
+
+ find "${ED}" \( -name '*.a' -or -name '*.la' \) -delete || die
+}