summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/liborcus/Manifest1
-rw-r--r--dev-libs/liborcus/liborcus-0.15.4.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/liborcus/Manifest b/dev-libs/liborcus/Manifest
index a5b0fbb55265..cf22a53a4ed4 100644
--- a/dev-libs/liborcus/Manifest
+++ b/dev-libs/liborcus/Manifest
@@ -1,2 +1,3 @@
DIST liborcus-0.14.1.tar.xz 1894680 BLAKE2B 0070baf319bf35275f36f3082141f154404ad43d8143588b35c00b8b536f0c1cf5bf38fd9e997c4be45a454f16de1cc1a25186da40e3ed0606a87e9a6a968053 SHA512 a32dc5a652ce99cff37273c38fb9460e13e7bfb562f40c8d0c79b65c33e340daaeeb2c796308ca700b85bfc13cc8215641563b9e9f6d44b7d61adb8e8a3c950f
DIST liborcus-0.15.3.tar.xz 1988748 BLAKE2B c011b7dabd1743e0f47518dbc900cd00fba046c7ad178d60116103307565bfe5ea6759752706715fe0ece4d31575b3453c193c1a5e92f8f9a4475e252d4564ae SHA512 bb5495a64ac5f984e107feb36dfe5c801d2ce7e2fcbee8f8bc779d87001e1fcb1d1f70ee2695eb976f1553c59908a15f887ceeb7ccfc556d4476ea846c5036f2
+DIST liborcus-0.15.4.tar.xz 1590048 BLAKE2B b2edff8a00439154c2850e49fff151f59c0c5a43163cebe5cac84b627fcf87c89a0a522797d8a5bc39eaca9205d74ff3f0bdf9ba77561c5cc7aefe98f35a4c8b SHA512 edbe1d6f86a249e43915e7fb960e6b269fa8703e3f571a023e811dd3f9b5d9c9a36edff491faa7ed7ea3490bf5afe1999e26d05c658a0a393b3ffd08b311b76f
diff --git a/dev-libs/liborcus/liborcus-0.15.4.ebuild b/dev-libs/liborcus/liborcus-0.15.4.ebuild
new file mode 100644
index 000000000000..91bbf3019d27
--- /dev/null
+++ b/dev-libs/liborcus/liborcus-0.15.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-single-r1
+
+DESCRIPTION="Standalone file import filter library for spreadsheet documents"
+HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/0.15" # based on SONAME of liborcus.so
+IUSE="python +spreadsheet-model static-libs tools"
+
+RDEPEND="
+ dev-libs/boost:=[zlib(+)]
+ sys-libs/zlib
+ python? ( ${PYTHON_DEPS} )
+ spreadsheet-model? ( >=dev-libs/libixion-0.15.0:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/mdds-1.5.0:1
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(use_enable python)
+ $(use_enable spreadsheet-model)
+ $(use_enable static-libs static)
+ $(use_with tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}