summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/appstream/Manifest1
-rw-r--r--dev-libs/appstream/appstream-0.14.3.ebuild77
2 files changed, 0 insertions, 78 deletions
diff --git a/dev-libs/appstream/Manifest b/dev-libs/appstream/Manifest
index 0d4d2a947cb1..93d00cd144b2 100644
--- a/dev-libs/appstream/Manifest
+++ b/dev-libs/appstream/Manifest
@@ -1,2 +1 @@
-DIST AppStream-0.14.3.tar.xz 2277536 BLAKE2B 99ceae6873c189b289143c8ab59eaacfbadbbe7cf05db96079c00ba09c82aeac63f4436e1b9e54b8d172aa7e9f609583cf2a78d3f44ce880cb1a326034432563 SHA512 b4c41b44375091636cc46e2f7f5e0b86612474faa6d55010caee78cb9c9ac468d093cf261184d900be7aae8513dc72d2821ff9ee17786e123c86a928ce5e9135
DIST AppStream-0.14.4.tar.xz 2309444 BLAKE2B 0c1fd20a01d0fe59d1b1ff029e4fbddbf9cea833d4665549480744e48dc0b3615b0d507278c75025c99ccda21b97e25e62496ecfc49dbe6527132f5dad5d6ad5 SHA512 86bd98e94f3e730d37030be31c6ea0000ba12b35e13778458c0f50bad75babf8c8e93b62492a2546a42f750f91ae81f3456d04e63ad9a4acb804cf38493440a4
diff --git a/dev-libs/appstream/appstream-0.14.3.ebuild b/dev-libs/appstream/appstream-0.14.3.ebuild
deleted file mode 100644
index 163beaa684e4..000000000000
--- a/dev-libs/appstream/appstream-0.14.3.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson xdg-utils
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ximion/${PN}"
-else
- SRC_URI="https://www.freedesktop.org/software/appstream/releases/AppStream-${PV}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
- S="${WORKDIR}/AppStream-${PV}"
-fi
-
-DESCRIPTION="Cross-distro effort for providing metadata for software in the Linux ecosystem"
-HOMEPAGE="https://www.freedesktop.org/wiki/Distributions/AppStream/"
-
-LICENSE="LGPL-2.1+ GPL-2+"
-# check as_api_level
-SLOT="0/4"
-IUSE="apt doc +introspection qt5 test"
-RESTRICT="test" # bug 691962
-
-BDEPEND="
- dev-libs/appstream-glib
- dev-libs/libxslt
- dev-util/itstool
- >=sys-devel/gettext-0.19.8
- doc? ( app-text/docbook-xml-dtd:4.5 )
- test? ( dev-qt/linguist-tools:5 )
-"
-RDEPEND="
- dev-db/lmdb:=
- >=dev-libs/glib-2.58:2
- dev-libs/libxml2:2
- dev-libs/libyaml
- dev-libs/snowball-stemmer
- net-misc/curl
- introspection? ( >=dev-libs/gobject-introspection-1.56:= )
- qt5? ( dev-qt/qtcore:5 )
-"
-DEPEND="${RDEPEND}
- test? ( qt5? ( dev-qt/qttest:5 ) )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-disable-Werror-flags.patch # bug 733774
-)
-
-src_prepare() {
- default
- sed -e "/^as_doc_target_dir/s/appstream/${PF}/" -i docs/meson.build || die
- if ! use test; then
- sed -e "/^subdir.*tests/s/^/#DONT /" -i {,qt/}meson.build || die # bug 675944
- fi
-}
-
-src_configure() {
- xdg_environment_reset
-
- local emesonargs=(
- -Dapidocs=false
- -Ddocs=false
- -Dcompose=false
- -Dmaintainer=false
- -Dstemming=true
- -Dvapi=false
- -Dapt-support=$(usex apt true false)
- -Dinstall-docs=$(usex doc true false)
- -Dgir=$(usex introspection true false)
- -Dqt=$(usex qt5 true false)
- )
-
- meson_src_configure
-}