summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/tomsfastmath/metadata.xml4
-rw-r--r--dev-libs/tomsfastmath/tomsfastmath-0.13.1.ebuild8
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-libs/tomsfastmath/metadata.xml b/dev-libs/tomsfastmath/metadata.xml
index 6e3769c91101..dfaf4142e2c6 100644
--- a/dev-libs/tomsfastmath/metadata.xml
+++ b/dev-libs/tomsfastmath/metadata.xml
@@ -9,4 +9,8 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
</pkgmetadata>
diff --git a/dev-libs/tomsfastmath/tomsfastmath-0.13.1.ebuild b/dev-libs/tomsfastmath/tomsfastmath-0.13.1.ebuild
index 3b61e419f34b..9518b0945ad2 100644
--- a/dev-libs/tomsfastmath/tomsfastmath-0.13.1.ebuild
+++ b/dev-libs/tomsfastmath/tomsfastmath-0.13.1.ebuild
@@ -5,8 +5,9 @@ EAPI=7
inherit toolchain-funcs
-DESCRIPTION="TomsFastMath is a fast public domain large integer arithmetic library"
-HOMEPAGE="https://www.libtom.net/TomsFastMath/ https://github.com/libtom/tomsfastmath"
+DESCRIPTION="Fast public domain large integer arithmetic library"
+HOMEPAGE="https://www.libtom.net/TomsFastMath/
+ https://github.com/libtom/tomsfastmath"
SRC_URI="https://github.com/libtom/tomsfastmath/releases/download/v${PV}/tfm-${PV}.tar.xz"
LICENSE="Unlicense"
@@ -47,8 +48,9 @@ src_test() {
# We choose to be verbose during the test process
# because the output is quite repetitive with no
# clear demarcation b/t tests
- tests=( "test" "stest" "rsatest" )
+ local tests=( "test" "stest" "rsatest" )
+ local test
for test in "${tests[@]}"; do
einfo "Running test (${test})"
./${test} || die "Test (${test}) failed"