summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/trio/Manifest1
-rw-r--r--dev-libs/trio/metadata.xml2
-rw-r--r--dev-libs/trio/trio-1.17.ebuild28
3 files changed, 30 insertions, 1 deletions
diff --git a/dev-libs/trio/Manifest b/dev-libs/trio/Manifest
index 59ec71d46d41..7f07d6f93d64 100644
--- a/dev-libs/trio/Manifest
+++ b/dev-libs/trio/Manifest
@@ -1 +1,2 @@
DIST trio-1.16.tar.gz 167337 BLAKE2B 0f284e0a130723f7511c0e874276c79c1addc1329833d14f0b76bae9808d90b76a2b26817ee85da71c3997360918cb534917a11bbe35ba627d1012cd8a2f6299 SHA512 3a8bac3ed001f70f498bd2ab0881ed6d3760bc978bf9ff587c3fc1d5d7a38205f779c5fe445f41edaa9e23c15bc1b4a521916e19161277741bc8e2f744b46c69
+DIST trio-1.17.tar.gz 452237 BLAKE2B 77ff673cc103b07b1424720d28c49d2e33a1402a98d8d21124fabb0cafd3498a99976d808cbbc5a90e1b3a063c6af68c3daf94768d533e4a762b730a253fa012 SHA512 19f4732b32c6a3754677d5766399fa70083c6a78c0d04b1dfa10a578b21405ba3e3d3af6543e4811f5fd305ec2727781a1b0f2888e59c574ca735f8406da7954
diff --git a/dev-libs/trio/metadata.xml b/dev-libs/trio/metadata.xml
index a7124f3f8f71..d2790650b579 100644
--- a/dev-libs/trio/metadata.xml
+++ b/dev-libs/trio/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo Games Project</name>
</maintainer>
<upstream>
- <remote-id type="sourceforge">ctrio</remote-id>
+ <remote-id type="github">orbea/trio</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-libs/trio/trio-1.17.ebuild b/dev-libs/trio/trio-1.17.ebuild
new file mode 100644
index 000000000000..cef261694cde
--- /dev/null
+++ b/dev-libs/trio/trio-1.17.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="media-gfx/imagemagick"
+DOCS_DIR="doc"
+
+inherit docs
+
+DESCRIPTION="Portable string functions, focus on the *printf() and *scanf() clones"
+HOMEPAGE="https://daniel.haxx.se/projects/trio/"
+SRC_URI="https://github.com/orbea/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="trio"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}