summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/mongo-cxx-driver/files/mongo-cxx-driver-1.1.2-boost-next.patch21
-rw-r--r--dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.1.2-r1.ebuild3
2 files changed, 23 insertions, 1 deletions
diff --git a/dev-libs/mongo-cxx-driver/files/mongo-cxx-driver-1.1.2-boost-next.patch b/dev-libs/mongo-cxx-driver/files/mongo-cxx-driver-1.1.2-boost-next.patch
new file mode 100644
index 000000000000..68bdc4dc1a4e
--- /dev/null
+++ b/dev-libs/mongo-cxx-driver/files/mongo-cxx-driver-1.1.2-boost-next.patch
@@ -0,0 +1,21 @@
+Add missing include for boost::next()
+
+https://bugs.gentoo.org/671422
+--- a/src/mongo/client/command_writer.cpp
++++ b/src/mongo/client/command_writer.cpp
+@@ -22,4 +22,6 @@
+ #include "mongo/db/namespace_string.h"
+
++#include <boost/next_prior.hpp>
++
+ namespace mongo {
+
+--- a/src/mongo/client/wire_protocol_writer.cpp
++++ b/src/mongo/client/wire_protocol_writer.cpp
+@@ -22,4 +22,6 @@
+ #include "mongo/db/namespace_string.h"
+
++#include <boost/next_prior.hpp>
++
+ namespace mongo {
+
diff --git a/dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.1.2-r1.ebuild b/dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.1.2-r1.ebuild
index 4b2e018de535..2dad30753129 100644
--- a/dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.1.2-r1.ebuild
+++ b/dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.1.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -33,6 +33,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-1.1.0-fix-scons.patch
"${FILESDIR}"/${PN}-1.1.2-boost-ref.patch
+ "${FILESDIR}"/${PN}-1.1.2-boost-next.patch
)
S="${WORKDIR}/${PN}-legacy-${PV}"