summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-ppcre-unicode')
-rw-r--r--dev-lisp/cl-ppcre-unicode/Manifest2
-rw-r--r--dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.0-r1.ebuild (renamed from dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild)17
-rw-r--r--dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.2.ebuild (renamed from dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.0.ebuild)19
3 files changed, 18 insertions, 20 deletions
diff --git a/dev-lisp/cl-ppcre-unicode/Manifest b/dev-lisp/cl-ppcre-unicode/Manifest
index 2ace7fade36c..47eafcd5ee1a 100644
--- a/dev-lisp/cl-ppcre-unicode/Manifest
+++ b/dev-lisp/cl-ppcre-unicode/Manifest
@@ -1,2 +1,2 @@
-DIST cl-ppcre-2.0.11.tar.gz 158418 BLAKE2B d65aa1a565dbe6c9d10e4dafe323ab1332929e46e00ea2e9775ad940ed5ac983520c0e423daa17bf0173420d2269b5af2fd9b52f8d3dbcb0c778e03e61ef052d SHA512 c693c568065c0571e5509599018e58951425a857cec3793312af0d22e248e32233f924eafc8ba67fbedad38cb3f4efa11343b785b073eaac53c31871422488b1
DIST cl-ppcre-2.1.0.tar.gz 159051 BLAKE2B d1b9dd93c3f4c4c3a23a7c01f28cc4a8cc8543bfa3280f60b53d61dadb377f9e45c0f79592323bb7dcaf06721d899159f958f5b7d391370eeb5c6ede81a7a0cd SHA512 c9c95c58628fd5ecebf6e24e0c26913719360c325e90e78c256d1306eb8c2cbe85a2a5f617fdb6c2a7091bd80f4021ad0d294371b2696ad8e5873eca13aab866
+DIST cl-ppcre-2.1.2.tar.gz 159376 BLAKE2B 73ca66402066401e52bc685bf2cd1a66a15b7688e3415ffa1eac2de28bbc577808752122bcb56967c061a83a547046bd3c2667fbaa5dc37d135b6cf67f29e10b SHA512 bfcea40b251a21861dae4883f6d5b277626ae2bed86fb895173e011bdf35a289eee949a3a87b3e83ed123ae22f2a19268038e624b378fd98d28855dda9e11f78
diff --git a/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.0-r1.ebuild
index 0a98f781406a..5486feaaf190 100644
--- a/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild
+++ b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.0-r1.ebuild
@@ -1,24 +1,23 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit common-lisp-3
DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp"
-HOMEPAGE="http://weitz.de/cl-ppcre/
- http://www.cliki.net/cl-ppcre"
+HOMEPAGE="https://edicl.github.io/cl-ppcre/
+ https://www.cliki.net/cl-ppcre"
+
SRC_URI="https://github.com/edicl/cl-ppcre/archive/v${PV}.tar.gz -> cl-ppcre-${PV}.tar.gz"
+S="${WORKDIR}/cl-ppcre-${PV}"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ~sparc x86"
-IUSE=""
-RDEPEND="=dev-lisp/cl-ppcre-${PV}
- dev-lisp/cl-unicode"
-
-S="${WORKDIR}/cl-ppcre-${PV}"
+RDEPEND="~dev-lisp/cl-ppcre-${PV}
+ dev-lisp/cl-unicode"
src_install() {
common-lisp-install-sources ${PN}/ test/unicode*
diff --git a/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.0.ebuild b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.2.ebuild
index 140ebc0154d6..70a4212613df 100644
--- a/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.0.ebuild
+++ b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.2.ebuild
@@ -1,24 +1,23 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit common-lisp-3
DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp"
-HOMEPAGE="http://weitz.de/cl-ppcre/
- http://www.cliki.net/cl-ppcre"
+HOMEPAGE="https://edicl.github.io/cl-ppcre/
+ https://www.cliki.net/cl-ppcre"
+
SRC_URI="https://github.com/edicl/cl-ppcre/archive/v${PV}.tar.gz -> cl-ppcre-${PV}.tar.gz"
+S="${WORKDIR}/cl-ppcre-${PV}"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
+KEYWORDS="~amd64 ~ppc ~riscv ~sparc ~x86"
-RDEPEND="=dev-lisp/cl-ppcre-${PV}
- dev-lisp/cl-unicode"
-
-S="${WORKDIR}/cl-ppcre-${PV}"
+RDEPEND="~dev-lisp/cl-ppcre-${PV}
+ dev-lisp/cl-unicode"
src_install() {
common-lisp-install-sources ${PN}/ test/unicode*