summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luafilesystem/luafilesystem-1.6.2.ebuild')
-rw-r--r--dev-lua/luafilesystem/luafilesystem-1.6.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-lua/luafilesystem/luafilesystem-1.6.2.ebuild b/dev-lua/luafilesystem/luafilesystem-1.6.2.ebuild
new file mode 100644
index 000000000000..334a50e1de9d
--- /dev/null
+++ b/dev-lua/luafilesystem/luafilesystem-1.6.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib toolchain-funcs
+
+DESCRIPTION="File System Library for the Lua Programming Language"
+HOMEPAGE="http://keplerproject.github.com/luafilesystem/"
+SRC_URI="mirror://github/keplerproject/luafilesystem/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/lua-5.1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "s|/usr/local|/usr|" \
+ -e "s|/lib|/$(get_libdir)|" \
+ -e "s|-O2|${CFLAGS}|" \
+ -e "/^LIB_OPTION/s|= |= ${LDFLAGS} |" \
+ -e "s|gcc|$(tc-getCC)|" \
+ config || die
+}
+
+src_install() {
+ emake PREFIX="${ED}usr" install
+ dodoc README
+ dohtml doc/us/*
+}