summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lualdap/Manifest1
-rw-r--r--dev-lua/lualdap/lualdap-1.3.1.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-lua/lualdap/Manifest b/dev-lua/lualdap/Manifest
index fee4147b5b72..acdc409ca153 100644
--- a/dev-lua/lualdap/Manifest
+++ b/dev-lua/lualdap/Manifest
@@ -1 +1,2 @@
DIST lualdap-1.3.0.tar.gz 81987 BLAKE2B cd25cada91a3c330fb72ee1106298442c64b1bcae4a57f48937efb4311f70b53c5a0e96587caab4b1950b16d9957bb8c25b2b9e0d3753089f06fbae64180ff04 SHA512 dea4282928c5138a327cd97d3d8049341fac17b5e853440f5b0a6e115e3400bac908f24827d48e36bfe81720c7d2bacdc50ae189953ecbcdfb27cb23b78d0de8
+DIST lualdap-1.3.1.tar.gz 82290 BLAKE2B 8436f1b3cf6497a3aea19de74a2e06bf2bb9ba4951d7357584c5b29a4d37ea2c5d4877d6ea3d44fca42d19207366abdf6a017ce1953d283a7bc243d230081077 SHA512 29d622ecf63214ac26ade71478c383e4f1b7468097bf19b99b8209b3f6cbb2078298a149d64ba8a7ca4abe97aa45550982792fa4ac0a8014f7daf709fe725e9f
diff --git a/dev-lua/lualdap/lualdap-1.3.1.ebuild b/dev-lua/lualdap/lualdap-1.3.1.ebuild
new file mode 100644
index 000000000000..bc819abad462
--- /dev/null
+++ b/dev-lua/lualdap/lualdap-1.3.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A lua binding for the OpenLDAP client libraries"
+HOMEPAGE="https://github.com/lualdap/lualdap"
+SRC_URI="https://github.com/lualdap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="test"
+
+RDEPEND="
+ net-nds/openldap:=
+ ${LUA_DEPS}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${RDEPEND} )
+"
+
+HTML_DOCS=( "docs/." )
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "LBER_LIBDIR=/usr/$(get_libdir)"
+ "LDAP_LIBDIR=/usr/$(get_libdir)"
+ "LUA_INCDIR=$(lua_get_include_dir)"
+ "LUA_LIBDIR=/usr/$(get_libdir)"
+ )
+
+ emake "${myemakeargs[@]}"
+
+ popd || die
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}" || die
+ LUA_CPATH="./src/?.so" ${ELUA} tests/test.lua || die
+ popd || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ # Workaround, as 'make install' does not create this directory
+ dodir "$(lua_get_cmod_dir)"
+
+ local myemakeargs=(
+ "DESTDIR=${ED}"
+ "INST_LIBDIR=$(lua_get_cmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ popd || die
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}