summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ANSITerminal/ANSITerminal-0.7.ebuild')
-rw-r--r--dev-ml/ANSITerminal/ANSITerminal-0.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/ANSITerminal/ANSITerminal-0.7.ebuild b/dev-ml/ANSITerminal/ANSITerminal-0.7.ebuild
new file mode 100644
index 000000000000..d3bbbde4799a
--- /dev/null
+++ b/dev-ml/ANSITerminal/ANSITerminal-0.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis eutils
+
+DESCRIPTION="Module which offers basic control of ANSI compliant terminals"
+HOMEPAGE="https://github.com/Chris00/ANSITerminal"
+SRC_URI="https://github.com/Chris00/ANSITerminal/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+RDEPEND=""
+DEPEND="${DEPEND} dev-ml/oasis"
+IUSE=""
+
+DOCS=( "README.txt" "AUTHORS.txt" )
+
+src_prepare() {
+ oasis setup || die
+}