summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/async/async-0.16.0.ebuild')
-rw-r--r--dev-ml/async/async-0.16.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/async/async-0.16.0.ebuild b/dev-ml/async/async-0.16.0.ebuild
new file mode 100644
index 000000000000..3bd14cb8c36e
--- /dev/null
+++ b/dev-ml/async/async-0.16.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="https://github.com/janestreet/async"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+# Need qtest_lib, netkit_sockets
+# Unpackaged test deps
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/async_kernel:${SLOT}
+ dev-ml/async_rpc_kernel:${SLOT}
+ dev-ml/async_unix:${SLOT}
+ dev-ml/core:${SLOT}
+ dev-ml/core_kernel:${SLOT}
+ dev-ml/core_unix:${SLOT}
+ dev-ml/ppx_jane:${SLOT}
+ dev-ml/ppx_log:${SLOT}
+ dev-ml/ppx_module_timer:=
+ dev-ml/textutils:${SLOT}
+"
+DEPEND="${RDEPEND}"