summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/async_rpc_kernel/async_rpc_kernel-0.15.0.ebuild')
-rw-r--r--dev-ml/async_rpc_kernel/async_rpc_kernel-0.15.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/async_rpc_kernel/async_rpc_kernel-0.15.0.ebuild b/dev-ml/async_rpc_kernel/async_rpc_kernel-0.15.0.ebuild
new file mode 100644
index 000000000000..7e000a1b3ae6
--- /dev/null
+++ b/dev-ml/async_rpc_kernel/async_rpc_kernel-0.15.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Platform-independent core of Async RPC library"
+HOMEPAGE="https://github.com/janestreet/async_rpc_kernel"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/async_kernel:${SLOT}
+ dev-ml/protocol_version_header:${SLOT}
+"
+DEPEND="${RDEPEND}"