summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/base_quickcheck/base_quickcheck-0.15.0-r1.ebuild')
-rw-r--r--dev-ml/base_quickcheck/base_quickcheck-0.15.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/base_quickcheck/base_quickcheck-0.15.0-r1.ebuild b/dev-ml/base_quickcheck/base_quickcheck-0.15.0-r1.ebuild
new file mode 100644
index 000000000000..6cae9208977e
--- /dev/null
+++ b/dev-ml/base_quickcheck/base_quickcheck-0.15.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Randomized testing framework, designed for compatibility with Base"
+HOMEPAGE="https://github.com/janestreet/base_quickcheck"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base:=
+ dev-ml/fieldslib:=
+ dev-ml/ppx_base:${SLOT}
+ dev-ml/ppx_fields_conv:${SLOT}
+ dev-ml/ppx_let:${SLOT}
+ dev-ml/ppx_sexp_value:${SLOT}
+ dev-ml/splittable_random:${SLOT}
+"
+RDEPEND="${DEPEND}"