summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camldbm/files')
-rw-r--r--dev-ml/camldbm/files/hasgotfix.patch15
-rw-r--r--dev-ml/camldbm/files/include_fix.patch15
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/camldbm/files/hasgotfix.patch b/dev-ml/camldbm/files/hasgotfix.patch
new file mode 100644
index 000000000000..840ffcbe7f0f
--- /dev/null
+++ b/dev-ml/camldbm/files/hasgotfix.patch
@@ -0,0 +1,15 @@
+https://forge.ocamlcore.org/tracker/index.php?func=detail&aid=1202&group_id=278&atid=1189
+
+Index: camldbm-1.0/configure
+===================================================================
+--- camldbm-1.0.orig/configure
++++ camldbm-1.0/configure
+@@ -35,7 +35,7 @@ hasgot() {
+ ${CC:-cc} -I$1 -o hasgot.exe hasgot.c $3 $4
+ res=$?
+ rm -f hasgot.c hasgot.exe
+- return $?
++ return $res
+ }
+
+ dbm_include="not found"
diff --git a/dev-ml/camldbm/files/include_fix.patch b/dev-ml/camldbm/files/include_fix.patch
new file mode 100644
index 000000000000..16fb6bd1e96e
--- /dev/null
+++ b/dev-ml/camldbm/files/include_fix.patch
@@ -0,0 +1,15 @@
+https://forge.ocamlcore.org/tracker/index.php?func=detail&aid=1201&group_id=278&atid=1189
+
+Index: camldbm-1.0/Makefile
+===================================================================
+--- camldbm-1.0.orig/Makefile
++++ camldbm-1.0/Makefile
+@@ -51,7 +51,7 @@ libcamldbm.$(A): cldbm.$(O)
+ $(OCAMLOPT) -c $(COMPFLAGS) $<
+
+ .c.$(O):
+- $(OCAMLC) -c -ccopt "$(DBM_INCLUDE)" -ccopt "$(DBM_DEFINES)" $<
++ $(OCAMLC) -c -ccopt "$(DBM_INCLUDES)" -ccopt "$(DBM_DEFINES)" $<
+
+ depend:
+ $(OCAMLDEP) *.ml *.mli > .depend